This might seem like a silly point (I've done it several times)....

There is a button in the debug tab that (when clicked) bypasses all breakpoints. I've clicked it by accident (it's close to where you can clear all breakpoints) and spent hours pulling my hair out.

-----Original Message-----
From: WDSCI-L [mailto:wdsci-l-bounces@xxxxxxxxxxxx] On Behalf Of Glenn Gundermann
Sent: Wednesday, April 05, 2017 12:31 PM
To: Rational Developer for IBM i / Websphere Development Studio Client for System i & iSeries <wdsci-l@xxxxxxxxxxxx>
Subject: Re: [WDSCI-L] Problems debugging with RDi SEP - breakpoints have no effect

Hi Matt,

After Set Service Point Entry, and after executing my program, the Debug Perspective opens up. The source is displayed on the screen.
You can see a visual pin in the left side to show existing breakpoints.
You can right-click to add or remove. You can also double-click. I don't know how I'd be setting the break points in the wrong source.

The icons to step into, step over, etc. all work fine.

The Run To Location works as well. I can at least use this in place of the breakpoints for now.



Yours truly,

Glenn Gundermann
Email: glenn.gundermann@xxxxxxxxx
Work: (905) 486-1162 x 239
Cell: (416) 317-3144


On 5 April 2017 at 12:14, Tyler, Matt <matt.tyler@xxxxxxxxxxxxxx> wrote:

Do you create SEP for same program you are setting break point. Seems
like a dumb question but I have seen it before. Programs with break
points set are not stopped if they are not the SEP (at least it used
to work this way).

Also, when debug session imitates, press F6 to step to see if its stepping
as you expect. Then find your break point line, right click [you might
have to right click twice] then choose Run to location.

-Matt

-----Original Message-----
From: WDSCI-L [mailto:wdsci-l-bounces@xxxxxxxxxxxx] On Behalf Of Glenn
Gundermann
Sent: Wednesday, April 5, 2017 10:07 AM
To: Rational Developer for IBM i / Websphere Development Studio Client
for System i & iSeries <wdsci-l@xxxxxxxxxxxx>
Subject: Re: [WDSCI-L] Problems debugging with RDi SEP - breakpoints
have no effect

Hi Matt,

Thanks for your email.

Nothing is out of sync between object and source. No message in
green-screen.

I have unchecked "Terminate debug session on program completion". No
change.
I restarted RDi, Set Service Entry Point, started the application, it
stops at the top of the program but will not stop at a breakpoint.
After clicking Resume, the program runs past the breakpoints and completes.

No encrypting source. As mentioned, ENDDBGSVR/STRDBGSVR gets rid of
the error message "ERROR decoding EStdString".


Yours truly,

Glenn Gundermann
Email: glenn.gundermann@xxxxxxxxx
Work: (905) 486-1162 x 239
Cell: (416) 317-3144


On 5 April 2017 at 11:56, Tyler, Matt <matt.tyler@xxxxxxxxxxxxxx> wrote:

First guess at the last sentence is that you have a compiled object
out of sync with source code. Does the green screen debugger give
you a message when you first start it up?

Also in 9.5.x version the debugger has a new option titled "Terminate
debug session on program completion". I cannot be 100% certain I
understand this but it can affect the way programs are reactivated
in
debug
during subsequent calls. I use it with the option checked off.

Are you encrypting your program object source? "ERROR decoding
EStdString "

-Matt

-----Original Message-----
From: WDSCI-L [mailto:wdsci-l-bounces@xxxxxxxxxxxx] On Behalf Of
Glenn Gundermann
Sent: Wednesday, April 5, 2017 9:45 AM
To: Rational Developer for IBM i / Websphere Development Studio
Client for System i & iSeries <wdsci-l@xxxxxxxxxxxx>
Subject: [WDSCI-L] Problems debugging with RDi SEP - breakpoints
have no effect

Hi folks,

I'm using RDi version 9.5.1.1.

I love RDi but boy can it be frustrating when it doesn't work.

After successfully debugging with RDi several times through this
morning, it stopped working.
I closed RDi.

After starting RDi again, the SEP was not listed. After trying to
Set Service Entry Point, I received the "ERROR decoding EStdString" message.
Grrrr.

I tried to execute the program anyway.

When I executed the program that I was trying to debug, it stopped,
and yet RDi was not showing it in Debug. I could not click anything
to resume the program execution. I had to close RDi again.

After issuing ENDDBGSVR/STRDBGSVR, I was able to Set Service Entry
Point again without an error message.

Now the debugger won't stop at the breakpoints. I've removed and
added new breakpoints. Clicking Resume blows right through the
whole
program.

Green-screen STRDBG works fine.

Any suggestions would be appreciated.

Yours truly,

Glenn Gundermann
Email: glenn.gundermann@xxxxxxxxx
Work: (905) 486-1162 x 239
Cell: (416) 317-3144
--
This is the Rational Developer for IBM i / Websphere Development
Studio Client for System i & iSeries (WDSCI-L) mailing list To post
a message
email: WDSCI-L@xxxxxxxxxxxx To subscribe, unsubscribe, or change
list options,
visit: http://lists.midrange.com/mailman/listinfo/wdsci-l
or email: WDSCI-L-request@xxxxxxxxxxxx Before posting, please take a
moment to review the archives at http://archive.midrange.com/wdsci-l.
--
This is the Rational Developer for IBM i / Websphere Development
Studio Client for System i & iSeries (WDSCI-L) mailing list To post
a message email: WDSCI-L@xxxxxxxxxxxx To subscribe, unsubscribe, or
change list options,
visit: http://lists.midrange.com/mailman/listinfo/wdsci-l
or email: WDSCI-L-request@xxxxxxxxxxxx Before posting, please take a
moment to review the archives at http://archive.midrange.com/wdsci-l.

--
This is the Rational Developer for IBM i / Websphere Development
Studio Client for System i & iSeries (WDSCI-L) mailing list To post a
message
email: WDSCI-L@xxxxxxxxxxxx To subscribe, unsubscribe, or change list
options,
visit: http://lists.midrange.com/mailman/listinfo/wdsci-l
or email: WDSCI-L-request@xxxxxxxxxxxx Before posting, please take a
moment to review the archives at http://archive.midrange.com/wdsci-l.
--
This is the Rational Developer for IBM i / Websphere Development
Studio Client for System i & iSeries (WDSCI-L) mailing list To post a
message email: WDSCI-L@xxxxxxxxxxxx To subscribe, unsubscribe, or
change list options,
visit: http://lists.midrange.com/mailman/listinfo/wdsci-l
or email: WDSCI-L-request@xxxxxxxxxxxx Before posting, please take a
moment to review the archives at http://archive.midrange.com/wdsci-l.

--
This is the Rational Developer for IBM i / Websphere Development Studio Client for System i & iSeries (WDSCI-L) mailing list To post a message email: WDSCI-L@xxxxxxxxxxxx To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/wdsci-l
or email: WDSCI-L-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives at http://archive.midrange.com/wdsci-l.

As an Amazon Associate we earn from qualifying purchases.

This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.