Edmund,

Did the web-install of RDI 9.6.0.8, and code coverage is FIXED! Joy Joy!

Apparently, trying to load it from the download Image files did not work for me. Like I did in the distant past. User Error.

Code Coverage now works flawless for me! Joy Joy!

Happy Dance Time!

GO RDI! I cannot NOT do my current job without my beloved RDI! <Big Proud IBM RDI Smile!>

Thanks Edmund!


I am so happy to see and work with the vast improvements in RDI! Looking forward to the next Beta 9.6.0.9!

Sorry, about the PEBCAK issue, "Problem Exists Between Chair And Keyboard". <LOL>

PMR# TS004307953 code coverage issue has been CLOSED!



PS. Thanks to the dedicated IBM support of Mike Hockings! He went above and beyond to Help me out! Kudos!

Also thanks to Steve Ferrell!


Ken Killian


-----Original Message-----
From: Ken Killian
Sent: Thursday, October 8, 2020 7:30 AM
To: Rational Developer for IBM i <wdsci-l@xxxxxxxxxxxxxxxxxx>
Subject: RE: [WDSCI-L] RDI 9.6.0.8 code Coverage lock on program: QTESEPEH

Edmund,

Good Tip!

When I do an export settings, that is one of multiple settings that is not restored on import. It appears that the Export/Import gets approximately 95% of the settings. (Ball park estimate/guess) A few setting I have to do manually, since the import does not get 100% of the settings.

That is one of the first settings we did after re-install and brand new workspace.

My Microsoft Boss uses "Code Coverage" on the Microsoft side. But, we cannot seem to get it work on the IBM I RDi. A Setting has to be missing. I sent IBM support my full brand new workspace zipped up. Sadly, they are unable to duplicate my error.

Sad thing, it is used to work. So, some setting/switch has to be set. I presume/assume/guess. <puzzled-look>

My Microsoft boss wonders why I do NOT use code coverage every time. It is because I seem to be always running into debug/code coverage issues. I have told all my co-workers do NOT BOTHER me with RDI debug issues! I did not write the RDi, open a case with IBM Support. We purchased the extended support.


I tell my co-workers to use Green Screen Debug, it works EVERY SINGLE TIME WITHOUT FAIL! Too bad, RDI debug is not reliable. What good is a tool if it is not reliable? That has always been my main complaint about RDI. I just want it to work.

I Hope the beta might resolve these debug/code coverage issues.

Thanks!

Ken Killian

-----Original Message-----
From: WDSCI-L <wdsci-l-bounces@xxxxxxxxxxxxxxxxxx> On Behalf Of Edmund Reinhardt
Sent: Wednesday, October 7, 2020 6:12 PM
To: wdsci-l@xxxxxxxxxxxxxxxxxx
Cc: wdsci-l@xxxxxxxxxxxxxxxxxx
Subject: Re: [WDSCI-L] RDI 9.6.0.8 code Coverage lock on program: QTESEPEH

Make sure that you have Preferences>Run/Debug>IBM i Debug>Update
production files
checked.

This thread ...

Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2020 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].