× The internal search function is temporarily non-functional. The current search engine is no longer viable and we are researching alternatives.
As a stop gap measure, we are using Google's custom search engine service.
If you know of an easy to use, open source, search engine ... please contact support@midrange.com.



On Wed, 23 Nov 2022 at 04:23, Martijn van Breden
<m.vanbreden@xxxxxxxxxxxxxxxxxxxxxxxxxx> wrote:

What I've come to think as a result of your question is that the subprocedure in the service program is reading and updating some fields from a file that contains an encrypted value as well. It isn't touching the encrypted field but still. Could that cause behavior like this?

I don't have any encrypted columns, so no direct experience. But if
the service program needs to call other subprocedures or programs in
order to decrypt, or implement a trigger, or... anything - maybe it is
one of these subsequent calls that is returning the 'not found'?

The ACS script runs under a server prestart job which has a job user
of QUSER, and does a profile switch to your user. The 5250 job runs
its entire life as your user. This is the only difference that I can
think of between the two. If anything in the called code stack tests
the user profile, it needs to make sure it uses the appropriate one.

You have quite a puzzle there, Martijn!
--buck

As an Amazon Associate we earn from qualifying purchases.

This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.