I think I'd vote for it, as well.
Does anyone else find the redundancy between the select block and the
if-elseif-else block a little disconcerting? Seems to me that there
should be a clear distinction between the two. There never can be at
this point, so I tend to use a relatively inconsistent mix of the two
in my code based on what mood I am in. But the select syntax has a
potentially game changing syntax.