Too many possibilities from what you've told us.
Has this box ever sent SMTP mail?
Are you forwarding to another email server (on either side of the firewall)? And if yes, does it require authentication?
Your Tomcat server and your systems IP and port for sending email are not (should not) be the same
Does you firewall block all except an allowed list..
Your system and Tomcat are (are not) same dns ?
Jim Franz

----- Original Message ----- From: "James H. H. Lampert" <jamesl@xxxxxxxxxxxxxxxxx>
To: "Midrange Systems Technical Discussion" <midrange-l@xxxxxxxxxxxx>
Sent: Friday, February 15, 2013 9:04 PM
Subject: This is a weird one, re: email not getting out of our V6 box

On our production box:

I tried sending email out of a derivative of our Wintouch product, which
uses QTmmSendMail. Nothing gets out, and the STMFs passed to QTmmSndMail
don't get deleted.

I tried ending and restarting QMSF. No change, even with *CLEAR. I tried
ending and restarting SMTP. No change.

I tried grabbing a temporary authorization for Brad Stone's MAILTOOL. It
thinks it sent the message successfully, and yet it still never arrives.

Yet our Code-on-Demand system, running, so far as I'm aware, in a Tomcat
server on the same box (and so far as I recall, emailing out
authorization codes from Java) has no trouble emailing me an
authorization code for our QuestView product.

This is entirely too weird for me to deal with on a Friday evening,
almost an hour after I went off-duty.

This is the Midrange Systems Technical Discussion (MIDRANGE-L) mailing list
To post a message email: MIDRANGE-L@xxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
or email: MIDRANGE-L-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives

This thread ...


Return to Archive home page | Return to MIDRANGE.COM home page