Aha!!! Just as I thought. :)

Glad you found the issue. Thanks for posting the resolution.

On Mon, Jan 21, 2019 at 11:09 AM Charles Wilt <charles.wilt@xxxxxxxxx>
wrote:

Just a follow up....

It appears that other programs running in the job are leaving
connections/files open (by design (mostly?)) and once we happen to get a
socket# higher than 224 we start seeing issues in HTTP API; and the
response file and/or connection gets left open when HTTP API crashes.

The Java JVM for instance has 180+ open file descriptors, mostly to various
JAR files.

When we run our new HTTP API process all by itself in a job, we don't see
any issues.

Charles



On Fri, Jan 11, 2019 at 11:27 AM Charles Wilt <charles.wilt@xxxxxxxxx>
wrote:

Since the FTPAPI list is having problems, thought I'd post here...

Running v1.33 of HTTP API, and noticing connections sometimes being left
open by the HTTPS calls that use the http_req() procedure.

Noticeable only because it's happening in a set of long running job
making
50,000+ calls...

Problem manifested as "out of range" error
"One of the following has occurred in RPG procedure COMMTCP_FD in program
LIBHTTP/HTTPAPIR4: - A numeric length or start position is less than 1 or
too large for the string operation.describe her in this message"

as described here...
http://www.scottklement.com/archives/ftpapi/201504/msg00093.html

It seems we're a few versions behind...

Changes to version 1.39 from 1.38:

- Fixed ALGD0200 declaration in ENCRYPTR4 -- though, this should

not impact current users. (Thomas Raddatz)

- Correct international handling of $Version string in Cookie

header routines.

Changes to version 1.38 from 1.37:

- Added memory alloc/dealloc diagnostic routines

- Fixed memory leaks -- comm drivers were not cleaned up

- fixed mismatches with regular alloc vs xalloc

Changes to version 1.37 from 1.36:

- Fix problem where debugLevel not propagated properly

- Added buffering to COMMTCPR4 to improve LineRead performance

- Added buffering to COMMSSLR4 to improve LineRead performance

Changes to version 1.36 from 1.35:

- Fix problem where http_persist_close() would get a pointer error

if http_persist_open() failed during SSL handshake.


The changes in 1.36 and 1.38 seem most likely to be related. Trying to
get the latest version put on to test.

But I'm hoping somebody here as seen the issue and can confirm it's fixed
in a later version when I push management for the upgrade.

Thanks!
Charles

--
This is the Web Enabling the IBM i (AS/400 and iSeries) (WEB400) mailing
list
To post a message email: WEB400@xxxxxxxxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
visit: https://lists.midrange.com/mailman/listinfo/web400
or email: WEB400-request@xxxxxxxxxxxxxxxxxx
Before posting, please take a moment to review the archives
at https://archive.midrange.com/web400.



As an Amazon Associate we earn from qualifying purchases.

This thread ...

Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.