Not strange at all. This is what happens when you get UNIX code ported to a
platform that usually works. The UNIX code continue to work _most of the time_.

-Bob Cozzi
www.RPGxTools.com
RPG xTools - Enjoy programming again.


-----Original Message-----
From: web400-bounces@xxxxxxxxxxxx [mailto:web400-bounces@xxxxxxxxxxxx] On Behalf
Of Brad Stone
Sent: Wednesday, April 05, 2006 9:19 AM
To: Web Enabling the AS400 / iSeries
Subject: Re: [WEB400] Another SSI issue.

Here's an update on this issue.

I went to test and just tried running the SSI statement on
the URL.. to see if it worked alone.. Worked fine.

Then the application worked fine after that.

Then I tried a few other different links.  Got the error
[error processing this directive] and the same errors in
the error log.

I hit refresh.  It worked after that.

So I went through each unique link.  The first time it
would show the error... after a refresh it worked fine.
 Couldn't get the error to show up again.

Now that is odd.  :)

On Wed, 05 Apr 2006 08:00:24 -0500
 "Brad Stone" <brad@xxxxxxxxxxxx> wrote:
> It's sending a header for sure.  :)
> 
> Brad
> 
> On Tue, 4 Apr 2006 19:17:52 -0500
>  "Bob Cozzi" <cozzi@xxxxxxxxx> wrote:
> > Ah... my CGILIB *SRVPGM (in xTools) that mimics what
> > CGIDEV2 does always outputs
> > a valid HTTP head if the user did not send one
> > themselves. CGIDEV2 does NOT do
> > this, but it is required under Apache. Does your
> erpgsdk
> > do this or are you
> > actually sending the header? Perhaps the header isn't
> > being sent??
> > 
> > 
> > -Bob Cozzi
> > www.RPGxTools.com
> > RPG xTools - Enjoy programming again.
> > 
> > 
> > -----Original Message-----
> > From: web400-bounces@xxxxxxxxxxxx
> > [mailto:web400-bounces@xxxxxxxxxxxx] On Behalf
> > Of Brad Stone
> > Sent: Tuesday, April 04, 2006 6:58 PM
> > To: Web Enabling the AS400 / iSeries
> > Subject: [WEB400] Another SSI issue.
> > 
> > So, I've got another SSI issue.  This one SSI doesn't
> > seem
> > to want to work on one V5R2 machine, but it works fine
> on
> > another V5R2 machine.  (go figure).
> > 
> > I searched the online PTFs and didn't find anything
> > specific.
> > 
> > QP0ZPUTENVCCSID OF NETC  FAILED WITH ERRNO 3021 FOR CGI
> > /QSYS.LIB/ERPGSDK.LIB/CAT0002.PGM, referer:
> > /e-rpg/catmain
> > ZSRV_MSG0107: Premature end of script headers: File
> name
> > is
> > CAT0002.PGM, referer: /e-rpg/catmain
> > ZSRV_MSG0412: Unable to include
> "/e-rpg/cat0002?cat=100&"
> > in parsed file /QSYS.LIB/ERPGSDK.LIB/CATMAIN.PGM.,
> > referer:
> > /e-rpg/catmain
> > 
> > Usually when I get this error it's because of an issue
> > with
> > the HTTP headers not having 2 CRLFs, etc.  In this case
> > they're there for sure, and it works fine on one V5R2
> > machine, but not on another.
> > 
> > Other SSIs work fine.  It's just this one SSI, so I'm
> > guessing maybe it is a bug in the program as it seems
> > it's
> > the only one with the issue.
> > -- 
> > This is the Web Enabling the AS400 / iSeries (WEB400)
> > mailing list
> > To post a message email: WEB400@xxxxxxxxxxxx
> > To subscribe, unsubscribe, or change list options,
> > visit:
> http://lists.midrange.com/mailman/listinfo/web400
> > or email: WEB400-request@xxxxxxxxxxxx
> > Before posting, please take a moment to review the
> > archives
> > at http://archive.midrange.com/web400.
> > 
> > 
> > -- 
> > This is the Web Enabling the AS400 / iSeries (WEB400)
> > mailing list
> > To post a message email: WEB400@xxxxxxxxxxxx
> > To subscribe, unsubscribe, or change list options,
> > visit:
> http://lists.midrange.com/mailman/listinfo/web400
> > or email: WEB400-request@xxxxxxxxxxxx
> > Before posting, please take a moment to review the
> > archives
> > at http://archive.midrange.com/web400.
> > 
> 
> Bradley V. Stone
> BVS.Tools
> www.bvstools.com
> -- 
> This is the Web Enabling the AS400 / iSeries (WEB400)
> mailing list
> To post a message email: WEB400@xxxxxxxxxxxx
> To subscribe, unsubscribe, or change list options,
> visit: http://lists.midrange.com/mailman/listinfo/web400
> or email: WEB400-request@xxxxxxxxxxxx
> Before posting, please take a moment to review the
> archives
> at http://archive.midrange.com/web400.
> 

Bradley V. Stone
BVS.Tools
www.bvstools.com

As an Amazon Associate we earn from qualifying purchases.

This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2021 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.