|
I was having the same problem with what you described below also. I'm trying to come up with a way that I can apply universally, hence needed to declare "successful" as const. Thanks. That makes me feel a bit better now. Uummm. I haven't thought of using copy book yet. I hate variable that comes from copy book. I know, I know... Still hate it though. -----Original Message----- From: rpg400-l-bounces@xxxxxxxxxxxx [mailto:rpg400-l-bounces@xxxxxxxxxxxx] On Behalf Of Scott Klement However, that's not always what your subprocedure does. I use success/fail for lots of different types of subproocedures, not just validity checking. For example: if ( order_loadCustOrdersList() = SUCCESS ); Sure, i could rename it to read "order_CustOrderListLoadedSuccessfully" or something like that, but to me, it's no longer obvious that the subprocedure actually loads it the order list. At that point, it looks like you're just checking to see if it was successful, instead of actually doing the work. So for a routine that's primary purpose isn't to check something, I use the SUCCESS/FAIL constants. Hope that makes sense.
As an Amazon Associate we earn from qualifying purchases.
This mailing list archive is Copyright 1997-2024 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].
Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.