James Rich wrote:

On Fri, 8 Apr 2005, Sean Porterfield wrote:

'make install' will put a new X5250 resource file in /usr/local/share/x5250 (or whatever you passed to --prefix in configure). But the colors there are very standard. I think I changed the heirarchy of preferences since 0.4.6 and maybe I screwed up (I had to for some desktop systems like gnome). If x5250 isn't starting up with the resources you expect, start it with the --debug-resources option. This will cause it to print to stdout where it is finding its resources and which resources are set.

All X5250 files I have are the same. The difference is in the program versions. For the record, I'm using Fedora Core 3 with Gnome.


$ x5250 --debug-resources as400
Application resource database:
[nothing important here]
Server resource database:
foreground: #000000
background: #e6e6e6
User resource database:
Command line resource database:


OK, so it got #e6e6e6 from the server resource database (wherever that might be); the old version didn't use that (I guess.) I added a line to X5250 which fixed the problem.


x5250*background                : black

Thanks!
Sean

This thread ...

Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2020 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].