Jeff,

You're going to have to look for a version of the jtds driver that supports Java 1.3. Take a look on sourceforge jtds project and look at the archives. I think you'll find one. http://sourceforge.net/projects/jtds/files/jtds/

Replace the jtds jar file in your classpath with one of the ones found here. I can't readily tell which jtds version goes with which jre version. You may have to experiment. I found references in their help forum to using jtds with jre 1.2, so it must be in there somewhere. Apparently it won't run with jre 1.1.

Dan Kimmel

-----Original Message-----
From: java400-l-bounces@xxxxxxxxxxxx [mailto:java400-l-bounces@xxxxxxxxxxxx] On Behalf Of Jeff Burcher
Sent: Tuesday, April 24, 2012 12:53 PM
To: java400-l@xxxxxxxxxxxx
Subject: Java Version?

Hi,



I am receiving the following Java error message on the AS400 when I try to connect using SK's JDBCR4 JDBC_ConnProp



java.lang.UnsupportedClassVersionError: net/sourceforge/jtds/jdbc/Driver



I am currently running JDK 1.3.0 on V5R1M0. Am I just hopelessly out of date?



Thanks,



Jeff Burcher - IT Dept

Allred Metal Stamping

PO Box 2566

High Point, NC 27261

(336)886-5221 x229

jeff@xxxxxxxxxxxxxxx



--
This is the Java Programming on and around the IBM i (JAVA400-L) mailing list To post a message email: JAVA400-L@xxxxxxxxxxxx To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/java400-l
or email: JAVA400-L-request@xxxxxxxxxxxx Before posting, please take a moment to review the archives at http://archive.midrange.com/java400-l.




This thread ...

Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2020 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].