I've a J2EE application that is leaving behind a lot of TCP/IP
connections in a Time-Wait state. Does any one know what cause those
connections to stay in time-wait? I did a help on the state column and
the help explains Time-Wait state as below:

Waiting to allow the remote host enough time
to receive the local system's acknowledgment
to end the connection.





Below is what I see under option 3 of netstat:
Subset of TCP/IP Connections

System:
MCBELL4
Type options, press Enter.

3=Enable debug 4=End 5=Display details 6=Disable debug

8=Display jobs



Remote Remote Local

Opt Address Port Port Idle Time State

10.48.9.196 2561 as-signon 000:02:02 Time-wait

10.48.9.196 2564 as-signon 000:02:02 Time-wait

10.48.9.196 2568 as-data > 000:02:00 Time-wait

10.48.9.196 2569 as-data > 000:01:59 Time-wait

10.48.9.196 2570 as-signon 000:02:01 Time-wait

10.48.9.196 2571 as-signon 000:02:01 Time-wait

10.48.9.196 2572 as-data > 000:01:59 Time-wait

10.48.9.196 2573 as-data > 000:01:59 Time-wait

10.48.9.196 2574 as-signon 000:02:00 Time-wait

10.48.9.196 2579 as-signon 000:01:59 Time-wait

10.48.9.196 2580 as-data > 000:01:57 Time-wait

10.48.9.196 2581 as-signon 000:01:59 Time-wait


As an Amazon Associate we earn from qualifying purchases.

This thread ...


Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.