What else does javap -verbose return? Is it possible that there was a
problem transferring the .class to the i?

Gary

-----Original Message-----
From: java400-l-bounces@xxxxxxxxxxxx
[mailto:java400-l-bounces@xxxxxxxxxxxx]
On Behalf Of Mark Walter
Sent: Monday, March 30, 2009 7:36 AM
To: java400-l@xxxxxxxxxxxx
Subject: Java Version issues

I'm trying to run a java class on my 400. But I'm getting an
UnsupportedClassVersionError. I compiled the class in Netbeans with
version
1.4.2. Which is what java -version shows in QSH on the iSeries.

If I try to do a JAVAP -Verbose on the class, it returns major and minor
versions of both 0. Is there any way to debug this error further?

I can run this out of netbeans against this iSeries, but the class needs
to
run on the iSeries itself.

Thanks,

Mark

Mark Walter
Certified IBM System i Specialist
Paragon Consulting Services, Inc
mwalter@xxxxxxxxxxxxxxx
717-764-7909 ext. 126


This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2020 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].