Cross-posted to RPG400 and WEB400 lists.

A colleague is using Scott Klement's HTTPAPI routines and is running into an issue.  They have the following code:

       rc = http_url_post_xml( URL
                         : %addr(SOAP) + 2
                         : %len(SOAP)
                         : *null
                         : %paddr(Incoming)
                         : %addr(call_status)
                         : HTTP_TIMEOUT
                         : HTTP_USERAGENT
                         : 'text/xml'
                         : %trim(WSWSUR));

The program runs in a never-ending batch job.  They execute STRSRVJOB on the job and STRDBG on the program, and then set a breakpoint on the first line of the "Incoming" procedure.  It looks like the procedure is being executed because it writes to a file and records are indeed being written, but the breakpoint is never hit.

Before we dig a lot deeper or start using bigger debug hammers, is this an issue anyone else has seen?  I was wondering if perhaps there are multi-threading concerns with the HTTP APIs that might complicate service jobs.

Thanks as always!



As an Amazon Associate we earn from qualifying purchases.

This thread ...

Follow-Ups:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.