You will get that error if you have already read the standard
input.....once read, the pointer doesn't exist anymore.



-----Original Message-----
From: Michael_Schutte@xxxxxxxxxxxx
Reply-To: Web Enabling the AS400 / iSeries <web400@xxxxxxxxxxxx>
To: web400@xxxxxxxxxxxx
Subject: [WEB400] CGIDEV2 Function zhbGetInput
Date: Tue, 12 Feb 2008 13:55:13 -0500



I have a dev2 program that is executing zhbGetInput function to get the
browser input. The thing is, it's not necessary to do for this program.
There's no data to get. But I mistakenly left it in and at times the
procedure would end in error.... procedure or pointer error.

// Get input from browser
nbrVars = zhbGetInput(SavedQueryString : qusec);

This dev2 program is suppose to send the user to an error page when an
error has occurred. So techinically I do not need to execute that line of
code and I'm going to remove it... But I was just wondering why I would get
this error. Is it because the browser input is returning nothing?

Michael Schutte
Admin Professional
Bob Evans Farms, Inc.
"The Secret's the Sauce! Enjoy our new Bob-B-Q Pulled Pork Knife & Fork
Sandwich!"




As an Amazon Associate we earn from qualifying purchases.

This thread ...

Follow-Ups:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.