Hi again,

I installed some group PTFs and IPL'd and it fixed the problem.

My question now is, does anybody have any suggestions for speeding up Tomcat 4 on V5R1. It is up and running now but it is much slower than Tomcat 3 was on the iSeries and alot slower than Tomcat 4 running on my laptop. Should this be the case? A PC running Tomcat faster than an iSeries?

Robert


Robert Upshall wrote:
I have the /QIBM/ProdData/Java400/jdk13/lib/tools.jar in my class path.



David Morris wrote:

Mike,

Did you add the tools.jar to your classpath? On your PC, it would normally be found in common/lib but that won't work on the AS/400.

David Morris


rupshall@xxxxxxxxxxx 03/31/03 09:31AM >>>


Works fine on my workstation.

Wills, Mike N. (TC) wrote:

Try it on your workstation and see if you have the same problem.

-----Original Message-----
From: Robert Upshall [mailto:rupshall@xxxxxxxxxxx] Sent: Monday, March 31, 2003 9:59 AM
To: java400-l@xxxxxxxxxxxx; web400@xxxxxxxxxxxx Subject: [WEB400] Tomcat 4.1.24 on V5R1



I am trying to upgrade from Tomcat 3 to 4 on our AS400. I downloaded



the latest version, extracted it to the IFS, did the recommended optimization, and used the startup and shutdown scripts I found on iSeries Network. It started like a charm.

The problem is, I can view html pages and servlets, but when I try to



view a jsp I get an error. I think the error can be traced to this


part:


. ...


--- Nested Exception ---
java.lang.UnsatisfiedLinkError



com/ibm/as400/system/OS400Process.<init>([Ljava/lang/String;[Ljava/lang/Stri



ng;Ljava/lang/String;)V+54 (OS400Process.java:68)



java/lang/Runtime.exec([Ljava/lang/String;[Ljava/lang/String;Ljava/io/File;)



Ljava/lang/Process;+135 (Runtime.java:551)



org/apache/tools/ant/taskdefs/Execute$Java13CommandLauncher.exec(Lorg/apache



/tools/ant/Project;[Ljava/lang/String;[Ljava/lang/String;Ljava/io/File;)Ljav



a/lang/Process;+57 (Execute.java:647)
org/apache/tools/ant/taskdefs/Execute.execute()I+20 (Execute.java:428)




org/apache/tools/ant/taskdefs/compilers/DefaultCompilerAdapter.executeExtern



alCompile([Ljava/lang/String;I)I+249 (DefaultCompilerAdapter.java:452)

org/apache/tools/ant/taskdefs/compilers/JavacExternal.execute()Z+61 (JavacExternal.java:81)
org/apache/tools/ant/taskdefs/Javac.compile()V+153


(Javac.java:840)

org/apache/tools/ant/taskdefs/Javac.execute()V+123


(Javac.java:682)

org/apache/jasper/compiler/Compiler.generateClass()V+553 (Compiler.java:317)
org/apache/jasper/compiler/Compiler.compile()V+22 (Compiler.java:370)
org/apache/jasper/JspCompilationContext.compile()V+19 (JspCompilationContext.java:473)


....


Mainly the "com/ibm/as400/system/OS400Process", has anybody


experienced

this problem before or anything like this? I can include the


complete

log if anybody needs to see more. I think this is something I am missing on the 400 but I have no idea where to start.

Robert


_______________________________________________
This is the Web Enabling the AS400 / iSeries (WEB400) mailing list
To post a message email: WEB400@xxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/web400
or email: WEB400-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives
at http://archive.midrange.com/web400.




--


Robert Upshall
Professional Software of Amarillo
(806) 358-8928
rupshall@xxxxxxxxxxx



As an Amazon Associate we earn from qualifying purchases.

This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.