I'm getting an "EVFP0019 No subroutine or procedure declaration could be found in the source for the current selection." Error when debugging a sqlrpg pgm. Am in rdi 9.01 and using IBM I Service entry Points. Ignoring the error and taking the step commands generates copies (one for each step taken!) of the original source window with an "Uncaught exception in class "com.ibm.etools.iseries.parsers.ISeriesEditorRPGILESQLParser". Document parser was disabled."

Some necessary history. We've recently installed RTC/RDI & Arcad. Arcad inserts all this necessary ... "stuff" on top of your source:

*%CSTD===========================================================*
** Application. : FAS Isir Verification *
** Component. . : IVAPOE098 Type: SQLRPGLE *
**===============================================================*
** Sub-system . : *
** Function . . : *
** Sub-function : *
**%S=============================================================*
** Description of functions: *
** *
** *
** *
**%E=============================================================*
** AUTHOR: 00:00 *
** MODIFS: 01 JPRUCHA 05/28/2014 08:53 V 1.00.Q WI 1764 *
** FASW 00IW 01 E-Sign Document Triage Needed Determi *
** ** RHOLLAMO 05/28/2014 : T0208797 WI 1764 *
*%ECSTD==========================================================*
*%LOC: SRC=*L01 OBJ=*L01
h DftActGrp(*NO)
h ActGrp(*Caller)

All the asterisks are lined up in col 7. For me, Debug is choking on the *%LOC: statement. It appears to go right there immediately. Shouldn't the debugger ignore anything commented out? On a whim, I inserted a blank between the * and % and all was fine (* %LOC). My co-worker, who has been suffering for days with this problem, tried the same "fix" with no change - problem still happens. Removing all the Arcad "stuff" seems to usually fix the debug problem but then Arcad works worse. Sometimes debug works fine as is and then, all of sudden, stops working again.

Our pc support guy who has the thankless task of installing rtc/rdi 9.01 on everyone's laptop is supposed to be contacting IBM Support but I thought I would try here also.

TIA.

Jack Prucha
Programming Team Supervisor
College Foundation, Inc.
919.835.2530

This email, including any documents, files, or previous email messages attached to it, has been sent from an email account of College Foundation Inc., (CFI) and may contain confidential, proprietary, or legally privileged information belonging to CFI. If you are not the intended recipient, any dissemination, distribution, or copying of this email or its attachments is strictly prohibited. If you have received this email in error, please immediately notify the sender by email and destroy the original email and any attachments.

As an Amazon Associate we earn from qualifying purchases.

This thread ...


Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.