Am 21.01.2023 um 15:40 schrieb Alan Cassidy <cfuture@xxxxxxxxxxx>:

My shop is now at V7R4 and the V7R4 reference includes text about *AUTO. So it's not that either.

Well - the 7.4 RPG compiler for sure supports *AUTO - but I would bet, that the SQL pre-compiler doesn’t support it - maybe even not on 7.5.

It’s the same with LIKEREC(…:*ALL) - even 7.3 supports it, but the SQL pre-compiler doesn’t understand the „*ALL“ extension - only a plain LIKEREC keyword.

As I already wrote - the SQL pre-compiler is developed and supported by a different team - not Barbara’s team. So not every RPG feature works with SQL.

Let us know how this story ends - I quite curious about it.

Daniel

As an Amazon Associate we earn from qualifying purchases.

This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2023 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.