Thanks for the reply. I wonder if I'm having a problem because I am using
TELNET to go to another system.
I tried changing the TNAPIFUNC to start to the other IP Address but that
didn't work. I have to look at that some more.

Art

On Wed, Aug 8, 2018 at 10:43 AM Kevin Bucknum <Kevin@xxxxxxxxxxxxxxxxxxx>
wrote:

I had not used this before, but it looked interesting so I gave it a
try. I was able to get it into our main application and move around
without any major problems. I would have to get deep into something to
get to a numeric field, so I threw together a small test and it works
for me. I did have to tweak TNAPIFUNC. It is hardcoded to 127.0.0.1 and
the box I am working on doesn't allow unnamed display connections. This
looks interesting but it looks like I would have to know more about the
5250 stream to use it for anything productive.

My test - https://code.midrange.com/3cbbfd852b.html





Kevin Bucknum
Senior Programmer Analyst
MEDDATA/MEDTRON
Tel: 985-893-2550

-----Original Message-----
From: RPG400-L [mailto:rpg400-l-bounces@xxxxxxxxxxxx] On Behalf Of Art
Tostaine, Jr.
Sent: Tuesday, August 7, 2018 6:30 PM
To: RPG programming on the AS400 / iSeries
Subject: TNAPI (was Virtual Terminal API's)

Art Tostaine, Jr. <atostaine@xxxxxxxxx>
6:34 PM (32 minutes ago)
to RPG
With TNAPI I got through our login screen, typing TELNET to the other
system, signing on there, and pressing enter a few times, but I fail
once I get
to the first field in the user program. It's a menu and a 3 digit
numeric.

I tried SendtoLoc and also SendScrn but none of them are putting 003
in the
field.

Here is the log with some stuff removed.

R/T FUNCTIONS
Select: 000

##########################################################
######################
2018-08-07-19.02.05.328 SENT: 003

2018-08-07-19.02.05.355 RECV: 06,22 1 127.0.0.1
c XXX Inc.

Option can not be bl

ank||

I See the 003 being sent but it's not on the screen capture. Looks
like the
Enter is going. But the app says operation can't be blank. If I runi
it manually I
can enter 003 and press enter and it works.

Thanks, Art

--
Art Tostaine
--
--
This is the RPG programming on the IBM i (AS/400 and iSeries) (RPG400-L)
mailing list
To post a message email: RPG400-L@xxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
visit: https://lists.midrange.com/mailman/listinfo/rpg400-l
or email: RPG400-L-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives
at https://archive.midrange.com/rpg400-l.

Please contact support@xxxxxxxxxxxx for any subscription related
questions.

Help support midrange.com by shopping at amazon.com with our affiliate
link: http://amzn.to/2dEadiD




This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2019 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].