|
I always try to create readable (or "self documenting") code and always use
%eof instead of %eof(name), because IMO this is much more readable. It is
applying the priniciple of DRY (dont repeat yourself).
Unless, of course, the qualification is necessary. And this is an
exception.
chain (custno) CUSTFILE
if %found;
endif;
is much easier to read than:
chain (custno) CUSTFILE
if %found(CUSTFILE);
endif;
Because in the latter case each time you read the code you have to check
the qualification and if it really is referring to the last file operation.
Although in most cases this is always the case. And reading/interpreting the
unnecessary qualifier each time interferes with comprehending the code.
Also, when copying and pasting source you have to make sure you also change
the corresponding qualifier. Always using a (unnecessary) qualifier makes
you repeat the filename and this is then another source of error.
As an Amazon Associate we earn from qualifying purchases.
This mailing list archive is Copyright 1997-2024 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].
Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.