• Subject: optimization problems
  • From: "Juris Krikis Jr." <juris.rfb@xxxxxxxxxxx>
  • Date: Wed, 05 Nov 1997 19:32:45 +0200
  • Organization: Riga Stock Exchange

Hi!

        A simple ILE RPG/400 code which run fine with OPTIMIZE(*NONE) throws
"pointer not set for location referenced" with OPTIMIZE(*FULL) when
trying to do something like:

C     OrdBKeyL      KList
C                   KFld                    Sts
C                   KFld                    CodIsn
C                   KFld                    BidAsk
C                   Eval      Sts = 'A'
C                   Eval      CodIsn = IsinCode
C                   Eval      BidAsk = 'B'
C     OrdBKeyL      Chain(N)  FOrdPubL2                          40

        I am trying to debug the code with DBGVIEW(*SOURCE) still and it seems
like the error occurs in the last Chain(N)...
        Not using any pointers at all...

Hope You can help me with some advice...

                                                Juris.
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
* This is the RPG/400 Discussion Mailing List!  To submit a new         *
* message, send your mail to "RPG400-L@midrange.com".  To unsubscribe   *
* from this list send email to MAJORDOMO@midrange.com and specify       *
* 'unsubscribe RPG400-L' in the body of your message.  Questions should *
* be directed to the list owner / operator: david@midrange.com          *
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *


This thread ...


Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2020 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].