Thanks for the reply

My system is IBM i 7.2

Installation give me problems with the dependencies:

error: Failed dependencies:


krb5-libs >= 1.8.3-1 is needed by postgresql-9.3.5-1.ppc


openldap >= 2.4.23 is needed by postgresql-9.3.5-1.ppc


gettext >= 0.10.40 is needed by postgresql-9.3.5-1.ppc


postgresql-libs = 9.3.5-1 is needed by postgresql-9.3.5-1.ppc


AIX-rpm >= 6.1.0.0 is needed by postgresql-9.3.5-1.ppc


AIX-rpm < 6.2.0.0 is needed by postgresql-9.3.5-1.ppc


libc.a(shr.o) is needed by postgresql-9.3.5-1.ppc


libcrypto.a(libcrypto.so.1.0.1) is needed by postgresql-9.3.5-1.ppc


libintl.a(libintl.so.1) is needed by postgresql-9.3.5-1.ppc


libpq.a(libpq.so.5) is needed by postgresql-9.3.5-1.ppc


libpthreads.a(shr_xpg5.o) is needed by postgresql-9.3.5-1.ppc


libreadline.a(libreadline.so.5) is needed by postgresql-9.3.5-1.ppc


libssl.a(libssl.so.1.0.1) is needed by postgresql-9.3.5-1.ppc


libz.a(libz.so.1) is needed by postgresql-9.3.5-1.ppc

I have tried various versions but the results is the same.

Thanks.

Il giorno ven 15 nov 2019 alle ore 21:51 Mark Waterbury <
mark.s.waterbury@xxxxxxxxxxxxx> ha scritto:

Carlo,
What version/release of IBM_i or OS/400 you are trying to do this on? (it
may make a difference -- for IBM_i 5.4 or 6.1, you want AIX 5.3 packages,
for IBM_i 7.1 or 7.2, you want AIX 6.1 packages.)
That idevcloud page is "dated"... it mentions PostGreSQL ver. 8.4.8, but
PostGreSQL is now at 12.1

You can also find a copy of IBM's AIX XLC compiler and download the "free
trial", and you can install that under PASE ... see here:

https://www.ibm.com/us-en/marketplace/xl-cpp-aix-compiler-power
But, perhaps a better, more modern approach is to just use GCC? If you
are on a recent IBM_i version, (7.2, 7.3, 7.4), there are yum RPM packages
to just download and install that stuff easily.

Also, depending on your needs, you might find a pre-compiled binary
version of PostGreSQL for AIX ready to download and install, here:
http://www.perzl.org/aix/
(They appear to have PostGreSQL 9.3.5.1 pre-built for AIX.)
This site:
https://www.ibm.com/support/pages/aix-toolbox-linux-applications-downloads-alpha


also has copies of PostGreSQL 11.5 for AIX ...
See also:
http://www.bullfreeware.com/
for another good source of open source software packages for AIX.

I cannot guarantee that these will all just install and run "as is" under
PASE, but many often work.
Hope that helps ...
Mark S. Waterbury



On Friday, November 15, 2019, 2:40:10 PM EST, Carlo Bragagnolo <
carlo.bragagnolo@xxxxxxxxx> wrote:

Hi,
is there someone who managed to install PostgreSql as suggested here:

http://yips.idevcloud.com/wiki/index.php/Databases/PostgreSQL

I suppose that my problem is that the xlc command is missing.

Thanks for you help

--
Carlo Bragagnolo
--
This is the IBMi Open Source Roundtable (OpenSource) mailing list
To post a message email: OpenSource@xxxxxxxxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
visit: https://lists.midrange.com/mailman/listinfo/opensource
or email: OpenSource-request@xxxxxxxxxxxxxxxxxx
Before posting, please take a moment to review the archives
at https://archive.midrange.com/opensource.

Help support midrange.com by shopping at amazon.com with our affiliate
link: https://amazon.midrange.com

--
This is the IBMi Open Source Roundtable (OpenSource) mailing list
To post a message email: OpenSource@xxxxxxxxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
visit: https://lists.midrange.com/mailman/listinfo/opensource
or email: OpenSource-request@xxxxxxxxxxxxxxxxxx
Before posting, please take a moment to review the archives
at https://archive.midrange.com/opensource.

Help support midrange.com by shopping at amazon.com with our affiliate
link: https://amazon.midrange.com




As an Amazon Associate we earn from qualifying purchases.

This thread ...

Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.