Hi Mike,

The database connector is now an npm:
https://www.npmjs.com/package/idb-connector Follow the instructions for
installation and implementation.

Aaron Bartell



On Thu, Oct 4, 2018 at 2:14 PM Smith, Mike <Mike_Smith@xxxxxxxxxxxxxxxx>
wrote:

I've made progress I think.

I uninstalled 5733OPS
I tried updating NODEVER. NO GOOD
I then removed NODEVER and reinstalled. NO GOOD
Next I updated all the packages via YUM.

I can now use NODEVER
However my index.js script blow up now.
I think it has to do with
const db = require('/QOpenSys/QIBM/ProdData/OPS/Node6/os400/db2i/lib/db2a')

as I get the following
Cannot load module
/QOpenSys/QIBM/ProdData/OPS/Node6/os400/db2i/bin/db2ia.node.

I suspect I need to point to a new location for NODE.JS 10 but I haven't
been able to locate it so far.

MIke

-----Original Message-----
From: OpenSource <opensource-bounces@xxxxxxxxxxxx> On Behalf Of Smith,
Mike
Sent: Wednesday, October 3, 2018 10:39 AM
To: 'IBMi Open Source Roundtable' <opensource@xxxxxxxxxxxx>
Subject: [IBMiOSS] FW: error when running a node.js program

Aaron,
I'm going to start with the version and see if that fixes the problem.
However not knowing what I'm really doing, I'm having problems with that
as well.

I signed on to putty.
Ran NODE -v
Shows v6.11.5

Then I ran YUM install nodejs10
Appears to have installed.

Tried to run NODEVER LIST
This gives me errors Could not load program node:
rtld: 0712-001 Symbol
_ZNSt15_Sp_counted_ptrIDnLN9__gnu_cxx12_Lock_policyE2EE10_M_disposeEv was
referenced
from module node(), but a runtime definition
of the symbol was not found.
rtld: 0712-001 Symbol
_ZNSt16_Sp_counted_baseILN9__gnu_cxx12_Lock_policyE2EE10_M_destroyEv was
referenced
from module node(), but a runtime definition
of the symbol was not found.
rtld: 0712-002 fatal error: exiting.

Updated NODEVER from ACS. Reran NODEVER with same error.

I appear to have node 10 loaded, but I don't see how to force it to use
this version.
And I don't know what to do with the NODEVER errors.

Mike

From: Smith, Mike
Sent: Wednesday, October 3, 2018 9:50 AM
To: 'IBMi Open Source Roundtable' <opensource@xxxxxxxxxxxx>
Subject: error when running a node.js program

I am working through a CRUD node.js tutorial from LITMIS that I'm having a
bit of a problem with.

I have it mostly working except the update/delete.
I can read the data fine.

I tested the sql statement on the update by copying and pasting in STRSQL
and the statement runs fine.

I'm receiving the following
SQLSTATE=HY010 SQLCODE=-99999 Error occurred in SQL Call Level Interface<
https://linkprotect.cudasvc.com/url?a=https%3a%2f%2fwww.google.com%2fsearch%3fq%3dSQLSTATE%253DHY010%2bSQLCODE%253D-99999%2bError%2boccurred%2bin%2bSQL%2bCall%2bLevel%2bInterface%26rlz%3d1C1CHBF_enUS795US795%26oq%3dSQLSTATE%253DHY010%2bSQLCODE%253D-99999%2bError%2boccurred%2bin%2bSQL%2bCall%2bLevel%2bInterface%26aqs%3dchrome..69i57j69i60l2.1462j0j7%26sourceid%3dchrome%26ie%3dUTF-8&c=E,1,qxgpGtGtGny_CifbsMqXdSyeE6blMr83k2IDIteBFjKAgL3EeRK6dl9_sp8ZHuaxpzBFPVRLWTRNeOquSeNSBIxdaCNT_s4VDlBrQPRlEILdr_T9hA,,&typo=1


I found some references to this error indicating an issue with CCSSID. I
checked my sysval and it is set at 37. User profile set to use *sysval.

Any thing else I might check.?

Mike


NOTICE: This message, including any attachment, is intended as a
confidential and privileged communication. If you have received this
message in error, or are not the named recipient(s), please immediately
notify the sender and delete this message.
--
This is the IBMi Open Source Roundtable (OpenSource) mailing list To post
a message email: OpenSource@xxxxxxxxxxxx To subscribe, unsubscribe, or
change list options,
visit:
https://linkprotect.cudasvc.com/url?a=https%3a%2f%2flists.midrange.com%2fmailman%2flistinfo%2fopensource&c=E,1,04goN6hbduaZBllg5Z6XoQBNHfbp3vFxtzIUajZb8N8JB8ox3aqXeOBcowRvWHdGl6f5onOEnFCeSGNXRXpfmVw8RUwfOmSSZXmxGwArX9PJFqCe&typo=1
or email: OpenSource-request@xxxxxxxxxxxx Before posting, please take a
moment to review the archives at
https://linkprotect.cudasvc.com/url?a=https%3a%2f%2farchive.midrange.com%2fopensource.&c=E,1,FotpIkmBwatlTN6b6J5dS9lCZTnlT4s-TMRflf5_nLaXK_e6QM3PXDUvwvfIVR8unPg1JAjFoVjV5ihPfAnan_JJ0wvTBirXET5w6it8a0lh6Rk-SYoy8ULP1Hmu&typo=1
NOTICE: This message, including any attachment, is intended as a
confidential and privileged communication. If you have received this
message in error, or are not the named recipient(s), please immediately
notify the sender and delete this message.
--
This is the IBMi Open Source Roundtable (OpenSource) mailing list
To post a message email: OpenSource@xxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
visit: https://lists.midrange.com/mailman/listinfo/opensource
or email: OpenSource-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives
at https://archive.midrange.com/opensource.


This thread ...

Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2020 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].