The latest release of our new ERP software requires 7.1.

That was one of the questions I asked when selecting a new ERP, what
minimum version of IBM i do you support with your latest release.

Charles

On Thu, Dec 3, 2015 at 4:49 PM, <rob@xxxxxxxxx> wrote:

<snip>
To Rob's original point which touched on the pain of the various JVMs
for i: The Java *language* has actually been quite good about
preserving compatibility with earlier versions. In principle, any
valid Java 2 source code is valid Java 5 source code. I would say
there is a *useful* subset of Java which is valid on essentially all
JVMs.
</snip>

Probably.
<snip>
Yes, of course the real world can get a little messy.
</snip>

And here is where the rub is. No one wants to code using 8 year old
technology. There is a reason that there are newer versions of java. New
features have been added, 'oddities' have been fixed, additional support
has been added, and so on. People do not want to keep coding for ancient
stuff. "People on this other platform have these cool features" "Sorry,
but that would require Java x and we aren't allowed to use that because we
have to support all these back releases of IBM i"

Even "mainstream" IBM i shops are saying "You have to be on a current
version of IBM i for our to get any upgrades, patches, support, etc".
I question how long "current" will mean X-2. As of September 30 support
for 6.1 is gone, including by some of the 3rd parties. They've formally
announced it. That should mean they should be able to code using stuff
only available on 7.1 or higher. Start using the highest Java engine
available on 7.1, etc.


Rob Berendt
--
IBM Certified System Administrator - IBM i 6.1
Group Dekko
Dept 1600
Mail to: 2505 Dekko Drive
Garrett, IN 46738
Ship to: Dock 108
6928N 400E
Kendallville, IN 46755
http://www.dekko.com

--
This is the Midrange Systems Technical Discussion (MIDRANGE-L) mailing list
To post a message email: MIDRANGE-L@xxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/midrange-l
or email: MIDRANGE-L-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives
at http://archive.midrange.com/midrange-l.



This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2019 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].