Joe,

I have been using Tomcat for quite a while on the 400. It works pretty
well
for us. I would look at Tomcat 4.0.1. I put some shell scripts out on
the
iSeries-tookit website at http://iseries-toolkit.sourceforge.net that
will start
Tomcat. Follow the Anon CVS link through \CVSROOT\src\sh. The scripts
are called catalina400.sh and endcatalina400.sh. On a V4R5 system you
need to add an export to set the JDK to 1.3.

Those scripts do not use a security manager or any of the other startup

options. It is based on the standard Tomcat 4.0.1 in startup shell
script
so it shouldn't be hard to add what you need. If your system is current

on PTFs and you are running the 1.3 or 1.2.2 JDK, you can usually have

Tomcat running in less than an hour this way. I intend to add some
installation instructions in the next week or so to the iSeries-toolkit
site
that walk someone through the necessary steps. If there is any
interest,
I would also add Struts and updated Cocoon instructions.

David Morris

>>> joepluta@PlutaBrothers.com 01/03/02 12:23PM >>>
Thanks, Carl.  I appreciate the input.  This is similar to what I had
heard.
The thing I learned since my last post is that the adminclient
software
comes with the order of the 5733AS3 LPO.  Even though it's a free
product,
it has to be separately ordered.  My client is busy trying to get all
those
pieces in place.

There is also indeed a place on the IFS where the adminclient resides:

\QIBM\ProdData\WebASAdv\hosts\default_host\admin\install

I don't have the exact instructions, but basically I think it boils
down to
unzipping the appropriate JAR file (AIX, NT or Sun) onto your
workstation.

Your info on the standard edition is also correct.  As of version 4.0
of
Websphere, there is no longer a standard edition.  While not
horrifically
expensive, the $4000 for the Advanced Edition is hard to justify if
you
don't need EJB support.  Since we don't require EJB, we're going to
have a
Tomcat version of our product available, probably by the end of the
quarter.

Joe

> From: Carl Galgano
>
> I have done one WebSphere install on 5.1.  It was a mess.
>
> Also, from other info I have
> seen here on the list, the Standard version of WS will be drop
> and you will
> need to purchase the Advanced version.  For that reason, we have
been
> experimenting with Apache and Tomcat.



As an Amazon Associate we earn from qualifying purchases.

This thread ...


Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.