Is &mplib in your library list?  Maybe the format section has a problem and
should say:

FORMAT(&MPLIB/VOH0)

Alan Novick
Pressman Toy Corporation
New Brunswick, NJ

----- Original Message -----
From: "Richard B Baird" <rbaird@esourceconsulting.com>
To: <midrange-l@midrange.com>
Sent: Wednesday, December 05, 2001 8:41 AM
Subject: ovrdbf opnqryf mystery


Hey all,

i've got an ovrdbf, opnqryf mystery.  here is the code:

OVRDBF     FILE(VOH0) TOFILE(&MPLIB/VOH0) SHARE(*YES)
OVRDBF     FILE(BTHCOPY) TOFILE(QTEMP/BTHCOPY) SHARE(*YES)

OPNQRYF    FILE((&MPLIB/VOH0) (QTEMP/BTHCOPY)) +
             FORMAT(VOH0 *ONLY) +
             KEYFLD((*MAPFLD/BTCHID) (VCHNBR)) +
             JFLD((*MAPFLD/BBTCHID *MAPFLD/BTCHID *EQ)  +
                  (*MAPFLD/ORG     *MAPFLD/VORG   *EQ)) +
             MAPFLD((ORG       'BTHCOPY/ORG   ')  +
                    (VORG      'VOH0/ORG      ')  +
                    (AUSTDATE  'VOH0/AUSTDATE ')  +
                    (AUSTTIME  'VOH0/AUSTTIME ')  +
                    (AUSTUSR   'VOH0/AUSTUSR  ')  +
                    (AUSTORG   'VOH0/AUSTORG  ')  +
                    (BTCHID    'VOH0/BTCHID   ')  +
                    (BBTCHID   'BTHCOPY/BTCHID')  +
                    (TRNSORIG  'VOH0/TRNSORIG ')  +
                    (TRNCURN   'VOH0/TRNCURN  ')  +
                    (IVCEXCHR  'VOH0/IVCEXCHR ')  +
                    (PMTEXCHR  'VOH0/PMTEXCHR ')  +
                    (RCURINVC  'VOH0/RCURINVC ')  +
                    (RCURPAYM  'VOH0/RCURPAYM ')  +
                    (APFILLER  'VOH0/APFILLER ')  +
                    (CAFIL01   'VOH0/CAFIL01  ')  +
                    (USEFIL01  'VOH0/USEFIL01 '))

&mplib equals a valid library name.  all files that are overridden exist in
that library.   the job runs without that library in the *libl.

I've run in debug, the overrides exist as each one is executed.
when it gets to the opnqryf command, it bombs with "File VOH0 in library
*LIBL not found."

If I run it with the library in the library list, it works.  without the
library in the list, it doesn't work.

I know i've done this before, but i don't know what i've done wrong this
time.

thanks in advance,

Rick

_______________________________________________
This is the Midrange Systems Technical Discussion (MIDRANGE-L) mailing list
To post a message email: MIDRANGE-L@midrange.com
To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/cgi-bin/listinfo/midrange-l
or email: MIDRANGE-L-request@midrange.com
Before posting, please take a moment to review the archives
at http://archive.midrange.com/midrange-l.





As an Amazon Associate we earn from qualifying purchases.

This thread ...

Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.