R6 CSM Integrator

I've run into a little snag with a view in Shipped Items.

Seems when you use the Salesrep Name (afa1tx relationship to sales rep file) and the shipped item line has a sales rep equal to zero (default from COM) it will not display the record...but oddly enough it will still include the net sales in the total (if you are totaling the column). The export only pushes the records displayed...

Anyway, since salesrep zero does not exist in the sales rep table (and I can't get it to let me create it) I am in a bit of a quandary. I need to solve the problem because I want both rep number and rep name so users can push this stuff to excel and not have to do a vlookup to cobble in the name. Without going into a long explanation, can I do one of the following:

- either force create a salesrep zero with a appropriate name (and probably blow things up)
- create a sales rep 999 and then mass replace the rep number in the shipped item table (and cause a ton more problems because of all the other tables storing the sales rep number that will no longer match)

unless, of course, someone has a much more elegant solution...

Thanks!

Charley Simpson
Turbonetics




As an Amazon Associate we earn from qualifying purchases.

This thread ...

Follow-Ups:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2021 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.