I¹ve had similar odd responses like that from java (like no output);
loading the latest java group PTF has always fixed the problem.
--
Marshall Dunbar



-----Original Message-----
From: JAVA400-L <java400-l-bounces@xxxxxxxxxxxx> on behalf of Pete Helgren
<pete@xxxxxxxxxx>
Reply-To: Java Programming on and around the IBM i <java400-l@xxxxxxxxxxxx>
Date: Tuesday, October 18, 2016 at 10:42 PM
To: Java Programming on and around the IBM i <java400-l@xxxxxxxxxxxx>
Subject: Re: No Java in PASE

Hmmm....that might be. Something related to the the OSS product install
maybe?

Might query Kevin. I definitely remember this working a while back
because I had to verify versions at the command line. Perhaps a change
to an environment variable in the bowels of OSS. I'll check on that....

Thanks

Pete Helgren
www.petesworkshop.com
GIAC Secure Software Programmer-Java
LinkedIn - www.linkedin.com/in/petehelgren
Twitter - Sys_i_Geek IBM_i_Geek

On 10/18/2016 8:43 PM, dkimmel wrote:
Sysout directed somewhere other than the console?

<div>-------- Original message --------</div><div>From: Pete Helgren
<pete@xxxxxxxxxx> </div><div>Date:10/18/2016 5:14 PM (GMT-06:00)
</div><div>To: Java Programming on and around the IBM i
<java400-l@xxxxxxxxxxxx> </div><div>Subject: No Java in PASE </div><div>
</div>May have to cross post to OSS...here is the deal:

I have the /QOpenSys/QIBM/ProdData/JavaVM/jdk70/32bit/bin on my PATH
along with /QOpenSys/usr/bin and /usr/bin When I use either QP2TERM OR
SSH using something like puTTY, and type this:
java -version

I get nothing. Nada.....zippo. No response. No error. It just
returns.

Trying /QOpenSys/QIBM/ProdData/JavaVM/jdk70/32bit/bin/java -version ALSO
returns nothing. I know Java is installed. I have multiple java
dependent jobs running (some are submitted shell scripts) So I can't
quite figure out why at the command line I am getting nothing....ON BOTH
my partitions (7.1 and 7.2 - whatever I broke I was consistent...)

$ ls -l /usr/bin/java
lrwxrwxrwx 1 qsys 0 62 Jan 23 2015 /usr/bin/java
-> /QIBM/ProdData/Java400/bin/java

$ ls -l /QOpenSys/usr/bin/java
lrwxrwxrwx 1 qsys 0 78 Oct 26 2008
/QOpenSys/usr/bin/java -> ../../QIBM/ProdData/OS400/PASE/bin/java

Anyone bump into this before? Kind of weird...



--
This is the Java Programming on and around the IBM i (JAVA400-L) mailing
list
To post a message email: JAVA400-L@xxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/java400-l
or email: JAVA400-L-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives
at http://archive.midrange.com/java400-l.



As an Amazon Associate we earn from qualifying purchases.

This thread ...

Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.