MIDRANGE dot COM Mailing List Archive



Home » MIDRANGE-L » July 2008

Re: Anyone seen system report SSL cert expired a day early?



fixed

Do you have your UTC Offset sysval set?

We had a similar issue with Northeast User Group Conference web site, trying
to calculate the date when the late registration fee took effect.

Craig Pelkie

----- Original Message -----
From: "Bradley V. Stone" <bvstone@xxxxxxxxxxxx>
To: <MIDRANGE-L@xxxxxxxxxxxx>
Sent: Monday, July 28, 2008 2:41 PM
Subject: RE: Anyone seen system report SSL cert expired a day early?


Well, I did some tests on this. I set my system date back a day and boom,
worked fine. Set it back to the correct date and it reported that the
server certificate was expired.

So, looks like a little date math issue with the SSL APIs. Verified it on
2
other machines running V5R4.

Opening a PMR, but not getting very far. It will be hard to test I guess.
I would say look at the code! Date arithmatic is wrong. :)

Bradley V. Stone
BVSTools - www.bvstools.com
eRPG SDK - www.erpgsdk.com

--
This is the Midrange Systems Technical Discussion (MIDRANGE-L) mailing
list
To post a message email: MIDRANGE-L@xxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/midrange-l
or email: MIDRANGE-L-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives
at http://archive.midrange.com/midrange-l.







Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2014 by MIDRANGE dot COM and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available here. If you have questions about this, please contact