Anything in your Apache logs? Any joblogs on your system?



-----Original Message-----
From: Robert Rogerson [mailto:rogersonra@xxxxxxxxx]
Sent: Tuesday, May 29, 2018 1:37 PM
To: web400@xxxxxxxxxxxx
Subject: [WEB400] Help configuring test server...

Hi All,

I'm trying server a page from my test server but I'm getting a 403 Forbidden error.

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> <HTML><HEAD>
<TITLE>403 Forbidden</TITLE>
<script type="text/javascript"
src="http://gc.kis.v2.scr.kaspersky-labs.com/2556D0D1-8199-3543-9258-4A0A9892FBAB/main.js";
charset="UTF-8"></script></HEAD><BODY>
<H1>Forbidden</H1>
<P>You do not have permission to access /vuconsole/index.html on this server.</P> </body></html>

My configuration is as follows

# Configuration originally created by Create HTTP Server wizard on Thu Apr 26 16:11:20 PDT 2018 ScriptAliasMatch ^/rob/(.*) /QSYS.LIB/robPROD169.LIB/$1.PGM Alias /docs/ /www/rob/169/proddocs/htdocs/ Alias /vuconsole/ /www/rob/169/proddocs/htdocs/vuconsole/
Alias /swagger/ /www/rob/169/proddocs/swagger/ ScriptAliasMatch ^/rbtutorial/(.*) /QSYS.LIB/rbtutorial.LIB/$1.PGM ScriptAliasMatch ^/robPROD169/(.*) /QSYS.LIB/robPROD169.LIB/$1.PGM Listen *:3335 DocumentRoot /www/rob/169/proddocs/htdocs TraceEnable Off Options -ExecCGI -FollowSymLinks -SymLinksIfOwnerMatch -Includes -IncludesNoExec -Indexes -MultiViews LogFormat "%h %T %l %u %t \"%r\" %>s %b \"%{Referer}i\"
\"%{User-Agent}i\"" combined
LogFormat "%{Cookie}n \"%r\" %t" cookie
LogFormat "%{User-agent}i" agent
LogFormat "%{Referer}i -> %U" referer
LogFormat "%h %l %u %t \"%r\" %>s %b" common CustomLog logs/access_log combined LogMaint logs/access_log 7 0 LogMaint logs/error_log 7 0

SetEnvIf "User-Agent" "Mozilla/2" nokeepalive SetEnvIf "User-Agent" "JDK/1\.0" force-response-1.0 SetEnvIf "User-Agent" "Java/1\.0" force-response-1.0 SetEnvIf "User-Agent" "RealPlayer 4\.0" force-response-1.0 SetEnvIf "User-Agent" "MSIE 4\.0b2;" nokeepalive SetEnvIf "User-Agent" "MSIE 4\.0b2;" force-response-1.0 Header Always Set Access-Control-Allow-Origin "*"
<Directory />
   Order Deny,Allow
   Deny From all
</Directory>
<Directory /QSYS.LIB/rbtutorial.LIB>
   Order Allow,Deny
   Allow From all
   SetEnv QIBM_CGI_LIBRARY_LIST "rbtutorial; robPROD169; CANLIB; QGPL2; QGPL"
</Directory>
<Directory /www/rob/169/proddocs/swagger>
   Order Allow,Deny
   Allow From all
</Directory>
<Directory /QSYS.LIB/robPROD169.LIB>
   Order Allow,Deny
   Allow From all
   SetEnv QIBM_CGI_LIBRARY_LIST "robPROD169; CANLIB; QGPL2; QGPL"
</Directory>
<Directory /www/rob/169/proddocs/htdocs>
   Order Allow,Deny
   Allow From all
</Directory>
<Directory /www/rob/169/proddocs/htdocs/vuconsole>
   Order Allow,Deny
   Allow From all
</Directory>

If I enter myserver:3335/docs/ in a browser then I see the index.html page displayed as expected.

But when I enter myserver:3335/vuconsole/ (which I think I should be able to enter) I get the 403 Forbidden error.

I confirmed that QTMHHTTP has *R authority to both the vuconsole folder and the index.html document in the vuconsole folder.

Can anyone see what is wrong with my configuration?

Thanks,

Rob




As an Amazon Associate we earn from qualifying purchases.

This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.