× The internal search function is temporarily non-functional. The current search engine is no longer viable and we are researching alternatives.
As a stop gap measure, we are using Google's custom search engine service.
If you know of an easy to use, open source, search engine ... please contact support@midrange.com.



We are currently on V7R1 (apache 2.2) and looking at going to R2 or R3 later this year and that is on our check list to see what directives changed in apache 2.4.

I believe they also removed the allow/deny directives for doing authentication and authorization.

Back on June 9, 2014 Dan Burger wrote a small article on this on "The Four Hundred" web site




-----Original Message-----
From: WEB400 [mailto:web400-bounces@xxxxxxxxxxxx] On Behalf Of Jon Paris
Sent: Tuesday, May 16, 2017 9:29 AM
To: Web400@Midrange. Web400 <web400@xxxxxxxxxxxx>
Subject: Re: [WEB400] Changes/Bugs in Apache?

That is quite possible Jeff - we went direct from V7R1 to V7R3 and this is the first time I have tried to use these test services since then.
I have it working by using a simplified directive and having a separate AliasMatch for each web service. For now I'll live with that until I have more time to get a more generic process working.

For the record I am now simply using ScriptAlias /restsrv1 /qsys.lib/partner400.lib/restsrv1.pgm and ScriptAlias /restsrv2 /qsys.lib/partner400.lib/restsrv2.pgm etc. Luckily I only have three to test right now!


Jon Paris

www.partner400.com
www.SystemiDeveloper.com

On May 16, 2017, at 9:40 AM, Jeff Stojevich <jeff.stojevich@xxxxxxxxxxxxxx> wrote:

Is this one of the apache directives that changed when going from V7R1 to V7R2 or V7R3. There are come directives that worked in V7R1 but they changed and IBM said they will not be backward compatible.




-----Original Message-----
From: WEB400 [mailto:web400-bounces@xxxxxxxxxxxx] On Behalf Of Jon
Paris
Sent: Saturday, May 13, 2017 6:30 PM
To: Web400@Midrange. Com <web400@xxxxxxxxxxxx>
Subject: [WEB400] Changes/Bugs in Apache?

I have this directive in my Apache config (actually in the vhosts but
...)

ScriptAliasMatch ^/CGI/(.*) /QSYS.LIB/PARTNER400.LIB/$1.PGM

I have not changed it (honestly) and I am sure that it has been working for years. This might be the first time I have used it since moving to V7R3.

When I try to use it with a REST web service (i.e. additional data in the URL) I am getting very strange results.

This URL http://partner400.com/cgi/prodrpt2oa <http://partner400.com/cgi/prodrpt2oa> works just fine and runs the script correctly.

This one http://partner400.com/cgi/restsrv1/part1
<http://partner400.com/cgi/restsrv1/part1> gives

Not Found
The script request is not valid. The script is not executable.

The log indicates that no PGM object was identified. So just for
chuckles I added .pgm to the base URL i.e:
http://partner400.com/cgi/restsrv1.pgm/part1
<http://partner400.com/cgi/restsrv1.pgm/part1>

That works - kind of ... the correct routing takes place and the script is called BUT the ".pgm" text then gets _added_ to the end of the URL. i.e. "part1" is actually passed to the script as "part1.pgm". If I add a / following "part1" then ".pgm" is seen as the next element in the path.

I've searched for PTFs on the topic but am seeing nothing.

Anyone got any ideas? This is an Apache feature that we use a lot and the .pgm workaround will not work for some scripts. For example this URL http://partner400.com/cgi/restsrv2.pgm/quantityquery/?partnum=0000011&quantity=5 <http://partner400.com/cgi/restsrv2.pgm/quantityquery/?partnum=0000011&quantity=5> tags the ".pgm" onto the end of quantityquery <http://partner400.com/cgi/restsrv2.pgm/quantityquery/?partnum=0000011&quantity=5> even when the trailing / is present as shown.


Jon Paris

www.partner400.com
www.SystemiDeveloper.com

--
This is the Web Enabling the IBM i (AS/400 and iSeries) (WEB400)
mailing list To post a message email: WEB400@xxxxxxxxxxxx To
subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/web400
or email: WEB400-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives at http://archive.midrange.com/web400.


--
This is the Web Enabling the IBM i (AS/400 and iSeries) (WEB400)
mailing list To post a message email: WEB400@xxxxxxxxxxxx To
subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/web400
or email: WEB400-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives at
http://archive.midrange.com/web400.


--
This is the Web Enabling the IBM i (AS/400 and iSeries) (WEB400) mailing list To post a message email: WEB400@xxxxxxxxxxxx To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/web400
or email: WEB400-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives at http://archive.midrange.com/web400.



As an Amazon Associate we earn from qualifying purchases.

This thread ...

Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2023 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.