Is the file being mentioned in the CPF4131 message the one that you expect? Look at the compile listing and see what file is being picked up during the compile. Are they truly the same file?

Scott


-----Original Message-----
From: WEB400 [mailto:web400-bounces@xxxxxxxxxxxx] On Behalf Of RPGLIST
Sent: Friday, May 30, 2014 8:06 AM
To: web400@xxxxxxxxxxxx
Subject: [WEB400] Issue with File in Procedure for Web Service (IWS)

I have written a web service in rpgle and as long as I don't declare a file local to a procedure it runs fine with the IWS, but for some reason it doesn't like it local.

Has anyone else run into this or found a work around or can tell me what I might be doing wrong?

I'm getting a CPF4131 error (level check) but I can take the same code and run it in a green screen and its fine.

Lib lists are the same (web service versus green screen).


--
This is the Web Enabling the IBM i (AS/400 and iSeries) (WEB400) mailing list To post a message email: WEB400@xxxxxxxxxxxx To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/web400
or email: WEB400-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives at http://archive.midrange.com/web400.



As an Amazon Associate we earn from qualifying purchases.

This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2021 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.