I'm not sure what the problem is. What XHTML version are you using, and what
browser?

I threw together a quick test in XHTML v1.0 Strict and it works fine.
http://jmack.parhelic.com/tmp/cookie_test.php


-----Original Message-----
From: web400-bounces@xxxxxxxxxxxx [mailto:web400-bounces@xxxxxxxxxxxx]On
Behalf Of Raul A. Jager W.
Sent: Friday, May 18, 2007 12:11 PM
To: Web Enabling the AS400 / iSeries
Subject: Re: [WEB400] Cookies in XHTML


The error console is clean, alert(document.cookie ) gives "undefined"
and setting a value seems just ignored.

Jordan Mack wrote:

I'm not sure why that would make a difference. You should be able to access
the document.cookie object from an xhtml document. If you have Firefox, open
the error console and check if there are any problems that popup.

-----Original Message-----
From: web400-bounces@xxxxxxxxxxxx [mailto:web400-bounces@xxxxxxxxxxxx]On
Behalf Of Raul A. Jager W.
Sent: Friday, May 18, 2007 11:45 AM
To: Web Enabling the AS400 / iSeries
Subject: [WEB400] Cookies in XHTML


In HTML I can set and read cookies using the "document.cookie" object,
but the same script does not work when the document type is xhtml.

Is there a way to use cookies in XHTML?

TIA.
Raúl




As an Amazon Associate we earn from qualifying purchases.

This thread ...

Follow-Ups:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.