Try adding Referencial Integrity to the related tables.

-----Original Message-----
From: web400-bounces+albartell=gmail.com@xxxxxxxxxxxx
[mailto:web400-bounces+albartell=gmail.com@xxxxxxxxxxxx] On Behalf Of
Corissa Andrascik
Sent: Tuesday, April 18, 2006 5:23 PM
To: web400@xxxxxxxxxxxx
Subject: [WEB400] Slow Query Performance from the Web

Hi All,
I'm new to this list - and I'm not sure this is the proper place to be
asking this question - but I'd appreciate any direction you can give.
We have a query that runs over a view that joins together several related
physical files. We created indexes for each physical based on the Where
clause in the query and when I run it through STRSQL on the
400 - the performance is good - about 8-9 seconds.   When the same query
is passed from the web - we're running websphere on Window 2003 boxes - it
takes in the neighborhood of 1 minute 10 seconds.
 We are trying to figure out what can be done to optimize it from the web.
I realize I'm probably not giving enough information here - I just have no
clue where to start!  If any of you have any ideas I'd be eternally
grateful.

Thanks



As an Amazon Associate we earn from qualifying purchases.

This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2021 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.