Justin, if you use DSPPGM DETAIL(*SRVPGM) on your program your will probably
find that it is bound to service program CGIDEV2/CGISRVPGM2.

Please try recreating the program with the CRTPGM command, making sure that
CGITEST is in the library list and CGIDEV2 is not and that you are binding to
CGITEST/CGISRVPGM2 (make sure that you are not using a binding directory that
binds to CGIDEV2/CGISRVPGM2).  Use DSPPGM again after recreating the program to
make sure the correct service program is being bound.

I still recommend using CGIDEV2/CGISRVPGM2 and the ADDLIBLE command in the CGI
program (CGIDEV2's DoCmd subprocedure makes this very easy to do).

Mel Rothman, CGIDEV2 Author
IBM eServer Custom Technology Center (CTC), Rochester, Minnesota
http://www-1.ibm.com/servers/eserver/iseries/service/ctc/
http://www.easy400.ibm.it/en


Justin Houchin wrote:
>
> I added the CGISRVPGM2 service program to my CGITEST library and I still get
> the same message. Like I said I have had running CGI Programs in this
> library using the Qzhbcgi Service program.
>
> Thanks
> Justin
> ----- Original Message -----
> From: "Mel Rothman" <mel@rothmanweb.com>
> To: <web400@midrange.com>
> Sent: Monday, May 13, 2002 3:08 PM
> Subject: Re: [WEB400] CGIDEV2
>
> > Justin, CGISRVPGM2 is CGIDEV2's service program.  Service programs are
> bound by
> > reference and have to be found at run time.
> >
> > Since you created the CGI program in a library other than CGIDEV2, the
> program
> > is not finding the service program.  You can solve this by either adding
> CGIDEV2
> > to the library list or using CRTDUPOBJ to make a copy of CGISRVPGM2 in
> library
> > CGITEST.
> >
> > The former solution is recommended because updates to the
> CGIDEV2/CGISRVPGM2
> > service program won't appear in library CGITEST unless you remember to
> CRTDUPOBJ
> > every time you update library CGIDEV2.
> >
> > Mel Rothman, CGIDEV2 Author
> > IBM eServer Custom Technology Center (CTC), Rochester, Minnesota
> > http://www-1.ibm.com/servers/eserver/iseries/service/ctc/
> > http://www.easy400.ibm.it/en
> >
> >
> > Justin Houchin wrote:
> > >
> > > I do not use the CGIDEV2 library. I created everything in the library
> named
> > > CGITEST. I have created CGI programs(not with the CGIDEV2 Service
> Program)
> > > before in that library that worked.
> > >
> > > Justin
> > > ----- Original Message -----
> > > From: "Scott Mildenberger" <Smildenber@Washcorp.com>
> > > To: <web400@midrange.com>
> > > Sent: Monday, May 13, 2002 2:38 PM
> > > Subject: RE: [WEB400] CGIDEV2
> > >
> > > > Is CGIDEV2 in the library list of the HTTP server job and do the two
> http
> > > > user profiles have authority to it?
> > > >
> > > > Scott Mildenberger
> > > >
> > > > > -----Original Message-----
> > > > > From: Justin Houchin [mailto:jhouchin9@charter.net]
> > > > > Sent: Monday, May 13, 2002 12:23 PM
> > > > > To: web400@midrange.com
> > > > > Subject: [WEB400] CGIDEV2
> > > > >
> > > > >
> > > > > This is a multi-part message in MIME format.
> > > > > --
> > > > > [ Picked text/plain from multipart/alternative ]
> > > > > Hi Everyone,
> > > > >     I am trying to create a CGI Program using CGIDEV2 Service
> > > > > Program, I am getting this error message when the program is
> executed:
> > > > >
> > > > >  Message ID . . . . . . :   MCH3401       Severity . . . . .
> > > > > . . :   40
> > > > >  Message type . . . . . :   Escape
> > > > >  Date sent  . . . . . . :   05/13/02      Time sent  . . . .
> > > > > . . :   12:57:53
> > > > >
> > > > >  Message . . . . :   Cannot resolve to object CGISRVPGM2.
> > > > > Type and Subtype
> > > > >    X'0203' Authority X'0000'.
> > > > >  Cause . . . . . :   Either a system pointer or a data
> > > > > pointer can not be
> > > > >    resolved.
> > > > >      For a system pointer, it can not be resolved to object
> > > > > CGISRVPGM2, type
> > > > >    and subtype X'0203', authorization X'0000', because either
> > > > > the named object
> > > > >    was not in any context referred to or the correct object
> > > > > was located but the
> > > > >    user profile did not have the required authority.
> > > > >      The object types for common type or subtype codes follow:
> > > > >      -- 0100-Access group, 0201-Program, 0401-Library,
> > > > >      -- 0701-Journal receiver, 0801-User profile, 0901-Journal,
> > > > >      -- 0B90-Data space, 0C90-Data space index, 0D50-Data
> > > > > base file member,
> > > > >  -- 0E01-Job queue, 0E02-Output queue, 0E03-Message file,
> > > > >  -- 0E04-Forms control table, 0A01-Data queue, 0E06-DBCS dictionary,
> > > > >  -- 0E07-Information search index, 1401-Class of service
> description,
> > > > >  -- 1501-Mode description, 0E05-Session description,
> > > > >  -- 1001-Device description, 1101-Line description,
> > > > >  -- 1201-Controller description, 1901-File, 1902-Message queue,
> > > > >  -- 1903-Job description, 1904-Class, 1905-Command, 1906-Table,
> > > > >  -- 1908-Edit description, 1909-Subsystem description,
> > > > >  -- 190A-Data area, 190C-Graphic symbol set, 190D-Chart format,
> > > > >  -- 1910-DBCS character table, 1911-Query definition, 1912-Folder,
> > > > >  -- 1915-Panel group, 1916-Menu group, 0E0D-Configuration list,
> > > > >  -- 1919-S/36 machine description, 1920-Data dictionary,
> > > > >  -- 1950-Data base directory, 1951-File format,
> > > > >      -- 19C2-Spool control block, 19D0-Work control block table,
> > > > >      -- 19D2-System value, 1A00-Process control space,
> > > > >      -- 1B01-Authorization list.
> > > > >      For a data pointer, it can not be resolved because the
> > > > > named object is not
> > > > >    located within any program activation currently known to
> > > > > the process.
> > > > >  Recovery  . . . :   Either specify the correct object name
> > > > > or specify the
> > > > >    correct authority for the object.
> > > > >
> > > > > I have made sure that the user profile Qtmhhttp and Qtmhhtp1
> > > > > have RX authority to the webpage in the IFS.
> > > > >
> > > > > Please HELP!!!!
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > Thanks,
> > > > >
> > > > > Justin Houchin
> > > > > Programmer
> > > > > Reliatek, Inc
> > > > > jhouchin9@charter.net
> > > > > Thanks,
> > > > >


This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2019 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].