Hi Matt,
Thanks for catching this, I have spoken to the developer and this will be
fixed for next release.
I assume that we should always use UPDPROD(*YES) rather than exposing this
as an option.
Unfortunately there is no work around available in the RDi 9.1



From: "Tyler, Matt" <matt.tyler@xxxxxxxxxxxxxx>
To: <wdsci-l@xxxxxxxxxxxx>
Date: 11/07/2014 06:35 PM
Subject: [WDSCI-L] RDi 9.1 Code Coverage DEBUG UPDPROD
Sent by: "WDSCI-L" <wdsci-l-bounces@xxxxxxxxxxxx>



For some reason Code Coverage uses STRDBG UPDPROD(*NO).



I know this because I get "Member XXXXXXXX cannot be opened while
UPDPROD(*NO)." then the coverage job ends.



I see no where I can set this debug option to UPDPROD(*YES). My debug
option under Preferences -> Run/Debug -> IBM i Debug has the option
"Update production files" set on.



We have overridden the system command default to be UPDPROD(*YES) and
its still at that value.



Did I miss an option in Code Coverage? Or does this require an RFE.



It makes this difficult to run Code Coverage without moving ALL
production level data objects to a test library. Sub programs that
are not in test are called attempting to open production data and
failing.





Thanks, Matt


As an Amazon Associate we earn from qualifying purchases.

This thread ...

Follow-Ups:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.