When are you looking?
Has the program ended and closed the file?
If it doesn't have unique keys it could be buffered

On Tue, 19 Feb 2019 at 17:09, <THarteau@xxxxxxxxxxxxxxxxxx> wrote:

Hi,
I have an RPLE program that has a file defined as UF with Add.
There is a subroutine that will only add records to the file, so I just
have a WRITE. I have one record that hits the WRITE and when I look at the
file, it is not there. I added an error indicator, but it is not set. The
fields all have the correct values. One thing odd was the previous record
written had a higher key field than the one I was trying to write, so I
added a SETLL before the WRITE. Still nothing. It appears all other
records are writing out correctly. Any ideas?

<===================================================>

Terri Harteau
Felker Brothers Corporation
****************
Practice random acts of kindness and senseless acts of beauty
-Anonymous
****************
--
This is the RPG programming on the IBM i (AS/400 and iSeries) (RPG400-L)
mailing list
To post a message email: RPG400-L@xxxxxxxxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
visit: https://lists.midrange.com/mailman/listinfo/rpg400-l
or email: RPG400-L-request@xxxxxxxxxxxxxxxxxx
Before posting, please take a moment to review the archives
at https://archive.midrange.com/rpg400-l.

Please contact support@xxxxxxxxxxxx for any subscription related
questions.

Help support midrange.com by shopping at amazon.com with our affiliate
link: https://amazon.midrange.com


This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2019 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].