If that cures it then IBM should have a fix for you in a while. The underlying problem is with the way that %Int/%Dec/%Float handle blanks. They should really treat them as zero and not an error (which is what they do now) hopefully in a future release we'll see a fix for that. In the meantime you can cure it by coding the elements as Alpha and testing/converting yourself.

Note this applies also to XML-INTO which is where I discovered the problem.


Jon Paris

www.partner400.com
www.SystemiDeveloper.com

On Nov 2, 2018, at 9:42 AM, Gerald Magnuson <gmagqcy.midrange@xxxxxxxxx> wrote:

when I change the data type from numeric to character those errors do go
away.....
but I think that will be problematic when there is numeric data that is
passed....
--
This is the RPG programming on the IBM i (AS/400 and iSeries) (RPG400-L) mailing list
To post a message email: RPG400-L@xxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
visit: https://lists.midrange.com/mailman/listinfo/rpg400-l
or email: RPG400-L-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives
at https://archive.midrange.com/rpg400-l.

Please contact support@xxxxxxxxxxxx for any subscription related questions.

Help support midrange.com by shopping at amazon.com with our affiliate link: https://amazon.midrange.com


This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2020 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].