× The internal search function is temporarily non-functional. The current search engine is no longer viable and we are researching alternatives.
As a stop gap measure, we are using Google's custom search engine service.
If you know of an easy to use, open source, search engine ... please contact support@midrange.com.



Interesting... I guess it wasn't tested before making it available. :)

I got v16 working, so I'll stick with that for now.

On Tue, Oct 18, 2022 at 10:17 AM Jesse Gorzinski <jgorzins@xxxxxxxxxx>
wrote:

https://github.com/soyuka/pidusage/issues/159

-----Original Message-----
From: OpenSource <opensource-bounces@xxxxxxxxxxxxxxxxxx> On Behalf Of
Brad Stone
Sent: Tuesday, October 18, 2022 9:35 AM
To: IBMi Open Source Roundtable <opensource@xxxxxxxxxxxxxxxxxx>
Subject: [EXTERNAL] Re: [IBMiOSS] What version of NodeJS is current for
IBM?

Well, I put it back to 14, and PM2 told me to update. So I did. Didn't
get the errors.

Switched to 16 and the same happened. And no more errors.

I am not going to use 18 for the time being. :)

On Tue, Oct 18, 2022 at 9:19 AM Brad Stone <bvstone@xxxxxxxxx> wrote:

I was updating my node from 14 to 16, then saw 18 was out too.

When I use 18 I got errors like this in PM2:
PM2 | Error caught while calling pidusage
PM2 | Error: os400 is not supported yet, please open an
issue (https://github.com/soyuka/pidusage )
PM2 | at get

(/QOpenSys/pkgs/lib/nodejs18/lib/node_modules/pm2/node_modules/pidusage/lib/stats.js:56:21)
PM2 | at pidusage

(/QOpenSys/pkgs/lib/nodejs18/lib/node_modules/pm2/node_modules/pidusage/index.js:30:5)
PM2 | at Object.getMonitorData

(/QOpenSys/pkgs/lib/nodejs18/lib/node_modules/pm2/lib/God/ActionMethods.js:60:5)
PM2 | at tasks
(/QOpenSys/pkgs/lib/nodejs18/lib/node_modules/pm2/lib/Worker.js:150:9)
PM2 | at Domain.<anonymous>
(/QOpenSys/pkgs/lib/nodejs18/lib/node_modules/pm2/lib/Worker.js:193:7)
PM2 | at Domain.run (node:domain:382:15)
PM2 | at Timeout.wrappedTasks [as _onTimeout]
(/QOpenSys/pkgs/lib/nodejs18/lib/node_modules/pm2/lib/Worker.js:192:7)
PM2 | at listOnTimeout (node:internal/timers:564:17)
PM2 | at process.processTimers
(node:internal/timers:507:7)

Then I changed my profile to use version 16.. ended SSHD, started up a
new session, checked the node version (it was 16) and started my app
again.

I am still getting the same error in the log... and it's reporting
nodejs18, not nodejs16. I even deleted all my apps from PM2 and
restarted them, but I can't get it to not report about node 18.

Should I stick with version 14? When I change it back to 14 I don't
get the errors.


--
This is the IBMi Open Source Roundtable (OpenSource) mailing list
To post a message email: OpenSource@xxxxxxxxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
visit: https://lists.midrange.com/mailman/listinfo/opensource
or email: OpenSource-request@xxxxxxxxxxxxxxxxxx
Before posting, please take a moment to review the archives
at https://archive.midrange.com/opensource.

Help support midrange.com by shopping at amazon.com with our affiliate
link: https://amazon.midrange.com


As an Amazon Associate we earn from qualifying purchases.

This thread ...

Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.