I have posted a similar message a few weeks ago to the web400 list and am
now cross posting with opensource and midrange.

The issue is that the number of XMLSERVICE jobs being started and never
stopping. Worst case to date is over 13,000 jobs started in about four
days.

The only option is to end the sub-system where they are running and
restart. (or manually 4=End)

This is happening on 3 systems all at V7R3 and current as of march 2018
with Cume, Groups and Hypers.

Two systems have Zend server installed on IBMi and the third has a remote
Linux Zend server and connecting via ODBC using XMLSERVICE

I have been advised that IBM does not provide support for Zend or
XMLSERVICE and was suggested to log any issues at
https://bitbucket.org/inext/xmlservice-rpg which I have done but firstly I
found this site somewhat difficult to navigate and am not totally sure I
have raised the issue correctly.

Unfortunately I find the documentation for XMLSERVICE most difficult to
read/understand and I know a few people agree with that opinion. This may
be as I am not used to the open source and still finding my way and what to
expect.

I am hoping there are controls/settings that allow XMLSERVICE jobs to be
re-used or to set a time-out where an inactive job will terminate.

Suggestions, comments, links most welcomed as to date I am not any closer
than I was a week or two ago at understanding this issue.

Don Brown



This thread ...


Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2020 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].