It looks like SQTY is defined with 2 decimals (since you say that it
displays as 1104615.00), so it is taking up 10 positions on the screen. Try
defining it with 0 decimals.

Vinay


On 10/13/09, J M Plank <plank.computer@xxxxxxxxx> wrote:

We have a requirement for a barcode with a value/field exit/value. We're
using TL Ashford for the label and using various Wasp scanners. The string
I'm testing is 0000015$M1104615 in code 39. In TLA, the actual code is
M¦04$MM¦01 (also used M¦04M¦08M¦01) where M¦04 is the quantity field, M¦08
is the $M and M¦01 is the item number. A label is created with this value
in the barcode. When this barcode is scanned into Word or Notepad, 0000015
is on the first line, 1104615 is on the second line, and the cursor is on
the third line, so it looks like it is working. In a display file, we are
getting either 1104615.00 in the quantity field (both values combined) or
0000015 with an "Enter key not allowed in field" message. We are expecting
a 0000015 in the quantity field and a 1104615 in the item field. The
vendor's code has:
A SQTY R B 8 12REFFLD(##QTY_TR)
A CHECK(RB)
A DSPATR(PC)
A EDTCDE(4)
A COLOR(TRQ)
A 8 24'Item.......:'
A 82 DSPATR(RI)
A SITEM R B 8 37REFFLD(##ITEM)
A CHECK(ER)
A COLOR(TRQ)
For SQTY, using CHECK(RB) or CHECK(RZ) or no CHECK had the "Enter key not
allowed in field" message. Using CHECK(FE) or CHECK(ER) puts both values
in
the same quantity field.

TLA says the barcode is correct ($M for field exit, $A for enter). Wasp
says the barcode works for them - although I suspect they did not test on
the i - waiting to hear back on that. They said the setting to use from
the
manual (Wasp WWS-800) was "on page 22 scan enter setup > full ascii > then
on page 21 scan update." I'd already done this, but I followed those
procedures again, with the same results.

Just for fun, if I position the cursor to the item number field and then
scan the barcode, the quantity (first) value displays in the item field and
the cursor is positioned at the beginning of the quantity field (CHECK(RB),
CHECK(RZ), CHECK(FE), CHECK(ER) and no CHECK) with no value displaying in
the quantity field.

The WWS-800 scanner and a Wasp light pen scanner both correctly scan in a
barcode on an earlier screen, which pulls up the screen I'm having problems
with.

I don't know what to check next. Any ideas? Originally I'd used hex
values
for the field exit with the same result - TLA said to use the $M instead.

Thanks.
Mark Plank
--
This is the Midrange Systems Technical Discussion (MIDRANGE-L) mailing list
To post a message email: MIDRANGE-L@xxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/midrange-l
or email: MIDRANGE-L-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives
at http://archive.midrange.com/midrange-l.



This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2020 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].