Folks, we just upgraded to V5R2 last weekend and things work fine except
for ODBC queries.

We make extensive use of COGNOS, which up to now (OS7400 V4R5...) gave us
no problems.

Since the update to V5R2, reports extracted from AS/400 database via Cognos
just show "part of the lines" we should get but NOT ALL !
So we just get "part of the rows" for the report but not all of them...

This happens bot with PC's running old Access Express 4.5 ( + SF64217) and
with PC's running the new Access for Windows 5.2 ( + SI10914).

Since we are BPCS users, during the upgrade to V5R2 we had to create a
QAQQINI file in QUSRSYS with the SUPPRESS_SQL_WARNINGS line in it.
We have tested with just this line only, and also after adding a line
QUERY_TIME_LIMIT  present in QSYS/QAQQINI  with a value of *NOMAX.

System value  QQRYTIMLMT = *NOMAX

Searching thru different forums (Midrange included, of course...) we've
found some entries dealing with this problem, with COGNOS and/or Windows
ACCESS. Someone mentioned an attribute called "Allow Query Timeout" in the
Advanced_Performance_options panel (Performance sheet in ODBC definition),
but as he himself mentioned, this did not fix it either... We tried it and
did not get any better.

Someone also pointed to some Windows Registry value he could not
remember...

Anyone has got a solution for this?
TIA

Juan Carlos


As an Amazon Associate we earn from qualifying purchases.

This thread ...

Follow-Ups:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.