I already compiled the ILE with FIXNBR(*ZONED). Let me explain what the exact
problem is -

In my ILE pgm, I have a statement as

MOVEL(P) AMLAD       @@D(01)

@@D is a alpha data structure with each field length as 50. I am reading AMLAD
from a PF. This field is defined as 5 packed (0 decimals!!). Some of the
records in the file contain blanks in this AMLAD. The hex value in this field
is '000000' . (dsppfm, F10, F11) Surprisingly no sign bit!! I beleive this
record is written into the file as a single field instead of moving valuies to
each field. Now my ILE pgm, when reading this AMLAD is giving me Data Decimal
error.

Unfortunately, the first 15 records in the file have this problem and the rest
of the records are having good data. But due to this, I am not able to go to
the good data. Any help/suggestions is appreciated. TIA.

Rgds
Venu
+---
| This is the Midrange System Mailing List!
| To submit a new message, send your mail to MIDRANGE-L@midrange.com.
| To subscribe to this list send email to MIDRANGE-L-SUB@midrange.com.
| To unsubscribe from this list send email to MIDRANGE-L-UNSUB@midrange.com.
| Questions should be directed to the list owner/operator: david@midrange.com
+---


This thread ...


Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2019 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].