• Subject: Re: RPGII to RPG400
  • From: "James W. Kilgore" <qappdsn@xxxxxxx>
  • Date: Thu, 07 May 1998 16:16:59 -0700
  • Organization: Progressive Data Systems, Inc.



Tim-Bar wrote:

> I have an RPGII program with a display file that I want to use "as is"
> in RPG400. I made the necessary changes to get the program to compile
> (F-specs). All the files are program-defined. I get an I/O device error
> because the O-specs are first in the cycle and there's no indicator on
> to output the screen. What changes are necessary to make this work?
> The client wants to migrate these programs with as few changes as
> possible.
>
>

1. Make sure your fields are initialized.
2. WRITE the first screen before you start your loop
3. If the program had a CP WORKSTN file (which you had to change to a CF) you 
did
write your own loop control didn't you?

+---
| This is the Midrange System Mailing List!
| To submit a new message, send your mail to MIDRANGE-L@midrange.com.
| To unsubscribe from this list send email to MIDRANGE-L-UNSUB@midrange.com.
| Questions should be directed to the list owner/operator: david@midrange.com
+---


This thread ...

Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2019 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available here. If you have questions about this, please contact [javascript protected email address].