I just grabbed the latest cvs source and compiled on Fedora Core 5.
When I use xt5250, the function keys are very strange.  I see Esc appear
on the screen and need to press another key before anything happens.

I've had this problem ever since James rearranged the source tree... but since nobody else has complained, I've been ignoring it.

The problem seems to stem from the fact that the configure.in script no longer sets USE_OWN_KEY_PARSING by default. (It used to, but it looks like James re-wrote configure.ac when he rearranged the source tree, and now it's not set by default.)

Try this:

a) Open up the curses/cursesterm.c source file.
b) Insert a line near the top that says:

    #define USE_OWN_KEY_PARSING

c) Re-compile.

See if that solves the problem for you. (It does for me, but I'm using FreeBSD, so YMMV).


got good results by pressing reset (my left ctrl) but started with Esc
and Enter (right ctrl) first.  Anyone have any idea if this problem is
in tn5250 or my environment?

Same problem here, but in a very different environment. I'd say it's TN5250.


As an Amazon Associate we earn from qualifying purchases.

This thread ...

Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.