Some x5250 bugs/questions:

Typeahead does not work right.  To reproduce this, type a CL command
that takes awhile, and then type something else while it's running.  For
example:
       DLYJOB DLY(10)
and while that's running, type WRKACTJOB (or whatever else) -- don't hit
enter -- when the DLYJOB is done, you'll see that the characters didn't
echo back correctly.

Screen still flickers like crazy.

There's extra spaces between the lines on the screen... perhaps 5-6 pixels
that are just "black".  That makes the x5250 window too big to fit "one
above" and "one below" on a 1024x768 resolution, which frustrates the heck
out of me.

It's also wider than xt5250... I assume that this is a font size issue.
Is there a way to set the fonts in x5250?  I tried the font_80 and
font_132 config keywords that work in the xterm, gtk and windows versions
of tn5250, but they didn't have any affect.

There should be a way to disable the cursor changing positions when you do
a middle-click to paste text.  It drives me nuts when I copy/paste and the
cursor moves to some random spot on the screen!

If I copy/paste to OpenOffice or Mozilla it grabs some garbage characters,
including "invisible" ones that don't take up any space on the screen, but
are there just the same.  I have the exact same problem with GTK-5250,
too...  but not with xt5250.

x5250 crashes with +enhanced when a window is displayed on the screen --
but I think you already know about that...

I wish I had more time to look at the code -- I'm sure I could resolve
these issues myself if I put the effort into it.

This thread ...

Follow-Ups:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2020 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].