Hello everyone!

I have set up lp5250d in linux correctectely and it prints fine, but with
the exception of one small detail: everytime I release a print job on the
as400 to the printer (env.DEVNAME = CONTLIN), it gives a msg saying that I
should "Put the *STD paper type in the printer CONTLIN." and that the paper
type was left blank. I always disregard the message, and press the G option,
and the printing turns out great.

Below is my tn5250rc file and the trace file:

--Start of tn5250rc file--
printer {
        host = as400
        env.DEVNAME = CONTLIN
        env.IBMMFRTYPMDL= *HP4
        outputcommand=scs2ascii | lpr -POnePrinter
        trace=/user/trace5250.txt
}

--End of tn5250rc file--

--Start of trace5250.txt--

lp5250d version 0.16.4, built on May 31 2002
host = as400
Non-Blocking
tn5250_char_map_new: map = "37"
HOST, This->status  = 8 0
GotVerb(2):<IAC><DO><NEWENV>
GotVerb(3):<IAC><DO><NEWENV>
HOST, This->status  = 8 0
GotVerb(2):<IAC><DO><TERMTYPE>
GotVerb(3):<IAC><DO><TERMTYPE>
GotSB:<IAC><SB><NEWENV><SEND>
        <USERVAR>IBMRSEED<85 61 81 34 CB DF 80 04>
        <VAR><USERVAR><IAC><SE>
SentSB:<IAC><SB><NEWENV><IS>
        <VAR>DEVNAME
        <USERVAR>CONTLIN
        <VAR>IBMMFRTYPMDL
        <USERVAR>*HP4
        <VAR>TERM
        <USERVAR>IBM-3812-1
        <VAR>IBMFONT
        <USERVAR>12
        <VAR>IBMTRANSFORM
        <USERVAR>1<IAC><SE>
GotSB:<IAC><SB><TERMTYPE><SEND><IAC><SE>
SentSB:<IAC><SB><TERMTYPE><IS>IBM-3812-1<IAC><SE>
HOST, This->status  = 8 1
GotVerb(2):<IAC><DO><END_OF_REC>
GotVerb(3):<IAC><DO><END_OF_REC>
HOST, This->status  = 8 1
GotVerb(2):<IAC><WILL><END_OF_REC>
GotVerb(3):<IAC><WILL><END_OF_REC>
HOST, This->status  = 8 1
GotVerb(2):<IAC><DO><BINARY>
GotVerb(3):<IAC><DO><BINARY>
HOST, This->status  = 8 1
GotVerb(2):<IAC><WILL><BINARY>
GotVerb(3):<IAC><WILL><BINARY>
tn5250_char_map_new: map = "37"
Dumping buffer (length=73):
@record +0000 004912a0 90000560 060020c0 003d0000   .... .-. .{ .
@record +0010 c9f9f0f2 e2e3c940 40404040 c3d6d5e3  I902STI     CONT
@record +0020 d3c9d540 40400000 00000000 00000000  LIN
@record +0030 00000000 00000000 00000000 00000000
@record +0040 00000000 00000000 00

@eor
tn5250_stream_get_record: offset = 11
HOST, This->status  = 8 1
GotVerb(2):<IAC><DO>8^D^H*^B@V^B@^P^B@^D^F
GotVerb(3):<IAC><DO>8^D^H*^B@^B@^P^B@^D^F

--End of trace5250.txt--

Has anybody had a similar problem has any sugestions?

Thanks in advance and a happy new year!

Best regards,

Rui Polido





This thread ...


Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2020 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].