• Subject: Re: new bug: locked up while viewing spool file
  • From: "paul cunnane" <paul@xxxxxxxxxxx>
  • Date: Mon, 14 Aug 2000 09:24:35 +0100

> 3) The END key still occasionally positions to the wrong place in SEU.
>       (it goes to the end of the field instead of the position following
>       the last nonblank character)  Again, I haven't been able to figure
>       out a pattern to this -- it works as it should most of the time.

I don't know if it has anything to do with this issue, but there are two
ways the AS/400 handles trailing blanks in a field.  Sometimes it fills with
actual blank (x'40') characters; sometimes it fills with what look like
nulls.  This is based on experience years ago with real 5250 terminals and
the extended display toggle (remember when that was a physical switch on the
front panel?).

So, if the End key handler is looking for the last non-blank character in a
field, maybe it is forgetting to take into account nulls as well?

Just a thought.

--
Paul


+---
| This is the LINUX5250 Mailing List!
| To submit a new message, send your mail to LINUX5250@midrange.com.
| To subscribe to this list send email to LINUX5250-SUB@midrange.com.
| To unsubscribe from this list send email to LINUX5250-UNSUB@midrange.com.
| Questions should be directed to the list owner/operator: david@midrange.com
+---

This thread ...

Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2020 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].