To tell OS400 to use a specific java version,

Go to the following (from iseries command line)

Wrklnk '/qibm/UserData/Java400/'
Then open SystemDefault.properties

You will see something like this in the file..... We set it up as java.version=1.6

************Beginning of data**************
java.version=1.6
os400.awt.native=true
os400.awt.headless=true
setenv DISPLAY=localhost:0.0
************End of Data********************

Hope this helps.

Murali.


-----Original Message-----
From: java400-l-bounces@xxxxxxxxxxxx [mailto:java400-l-bounces@xxxxxxxxxxxx] On Behalf Of Peter Clifford
Sent: 06 January 2010 15:06
To: java400-l@xxxxxxxxxxxx
Subject: HTTP ADMIN server failing


Hoping someone can help me. My java knowledge is very limited.



Our iSeries HTTP *ADMIN server is failing. We are on V6R1M0.



QSYSOPR shows:



Message ID . . . . . . : HTP8002
Date sent . . . . . . : 01/06/10 Time sent . . . . . . : 14:37:26

Message . . . . : HTTP Server instance ADMIN failed.

Cause . . . . . : HTTP Server instance ADMIN failed. See the job log for
job 208271/QTMHHTTP/ADMIN for more information.
Recovery . . . : Correct the problem identified in the job log and try the
request again.



The joblog for 208271/QTMHHTTP/ADMIN shows:



HTP8508 Diagnostic 40 01/06/10 14:37:15.251554 QZSRAPR QHTTPSVR *STMT QZTCJK QHTTPSVR *STMT
From module . . . . . . . . : QZSRSNDM
From procedure . . . . . . : sendMessageToJobLog_CCSID
Statement . . . . . . . . . : 27
To module . . . . . . . . . : JKJNIWK
To procedure . . . . . . . : validate
Statement . . . . . . . . . : 92
Message . . . . : Required licensed program 5722JV1 option *BASE is not
installed.
Cause . . . . . : The configuration of the HTTP server requires licensed
program 5722JV1 option *BASE to be installed. The HTTP server did not
start. Recovery . . . : Install licensed program 5722JV1, option *BASE,
and then start the server again.


So....



Why is it asking for 5722JV1 when (as I understood it) that is not the correct licensed program for V6R1M0? We have:



5761JV1 *BASE *COMPATIBLE V6R1M0
5761JV1 6 *COMPATIBLE V6R1M0
5761JV1 7 *COMPATIBLE V6R1M0



I'm guessing there's a setting soemwhere that tells OS/400 what version of java to use. Can somebody tell me where it i?



Thanks



_________________________________________________________________
Use Hotmail to send and receive mail from your different email accounts http://clk.atdmt.com/UKM/go/186394592/direct/01/
--
This is the Java Programming on and around the iSeries / AS400 (JAVA400-L) mailing list To post a message email: JAVA400-L@xxxxxxxxxxxx To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/java400-l
or email: JAVA400-L-request@xxxxxxxxxxxx Before posting, please take a moment to review the archives at http://archive.midrange.com/java400-l.



Consider the environment and think before you print this email.

Registered Address: Fortis House Tollgate Eastleigh Hampshire SO53 3YA Registered Number: 354568 England
Authorised and regulated by the Financial Services Authority

This e-mail together with any attachments are intended for the addressee only and may be private and confidential. If you are not the intended recipient, or the person responsible for delivering it to the intended recipient, you must not open any attachments, or copy, disclose, distribute, retain or use this e-mail, including any attachments, in any way whatsoever; please return it to us immediately using the reply facility on e-mail.

Consider the environment and think before you print this email.


As an Amazon Associate we earn from qualifying purchases.

This thread ...

Follow-Ups:
Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.