Joe skrev den 12-07-2007 03:11:
Could anyone give me any ideas as to why this class would not be
visible to the classpath when the Java program is called from within
an RPG module? It makes me wonder if there are different JVM's being
used. But when checking from QSH and JAVA *VERSION, the version
returned is 1.4.2.
My guess is that this is running under a 1.3 JVM.

Try to output the value of the system property "java.version" as the first line in your main method.

If this is the case and you cannot fix it, then find a suitable XML-parser (or XSLT-processor) depending on your needs and add it to the classpath. Saxon 6.5 has generally worked well for me.


As an Amazon Associate we earn from qualifying purchases.

This thread ...

Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2022 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.