I'm having trouble compiling a program calling your port of Expat from C++
(or to be honest, the code is 99% C).
Or to be more specific I'm having trouble getting the error listed so I can
do something about it...

Thank you,
Erik

2009/9/2 Scott Klement <c400-l@xxxxxxxxxxxxxxxx>

I'm not sure that I understand the problem. Are you having trouble
compiling Expat or compiling your own program? (Expat isn't C++!)

I've had no trouble compiling Expat on i, but I haven't tried calling it
from C, I always call it from RPG.


Erik Olsson wrote:
Tried to compile to V5R3 and 2. In both cases the compiler flags not 1
but 6
severe errors, but still does not provide any information about their
nature
or location.
I also tried taking out all C++ strings and replacing them with C ones,
as I
found messages on this list from a few years ago where that was a
problem. I
also did a char rather than wchar_t version, but that gives the same
undisclosed error.

--
This is the C programming iSeries / AS400 (C400-L) mailing list
To post a message email: C400-L@xxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/c400-l
or email: C400-L-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives
at http://archive.midrange.com/c400-l.



This thread ...

Replies:

Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2019 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].